Bug 1022072 - Pools indexed with incorrect provider_id, may not show up in the UI
Pools indexed with incorrect provider_id, may not show up in the UI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Kedar Bidarkar
: Triaged
: 1022489 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 11:20 EDT by Justin Sherrill
Modified: 2014-04-24 13:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-10-22 11:20:57 EDT
Description of problem:

Indexing of providers is using the following to lookup the product:

   product = Product.where(:cp_id => pool.product_id).first

Cp_id is not unique to an organization, so it needs to add a conditional org.  It will always grab the first one, so this is not something that can be easily reproduced in all orgs, but should be able to on a satellite with more than one org fairly easily. 



Steps to Reproduce:
1.  Create 3 orgs
2.  Import 3 different manifests all with the same subscription (i.e. Red Hat Employee Subscription)
3.  Visit the Content -> Subscriptions -> redhat subscriptions for each org

Actual results:
On or more orgs may have no subscriptions

Expected results:
The subscription should show up in each of the orgs

Additional info:

The correct query should be:

   product = Product.in_org(self.organization).where(:cp_id => pool.product_id).first
Comment 2 Justin Sherrill 2013-10-22 11:41:08 EDT
https://github.com/Katello/katello/pull/3243
Comment 5 Justin Sherrill 2013-10-23 16:31:10 EDT
*** Bug 1022489 has been marked as a duplicate of this bug. ***
Comment 6 Kedar Bidarkar 2013-10-24 07:04:45 EDT
Now different manifests but with same subscriptions are now visible via the UI in their respective orgs. Verified with MDP2 Snap7
Comment 7 Bryan Kearney 2014-04-24 13:09:40 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 8 Bryan Kearney 2014-04-24 13:11:06 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.