Bug 1022096 - Busy gvfsd-sftp blocking main thread
Busy gvfsd-sftp blocking main thread
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 1026866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 11:42 EDT by Mikhail
Modified: 2015-02-25 03:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-24 11:28:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtraces of evolution (60.00 KB, application/x-bzip)
2013-10-22 11:42 EDT, Mikhail
no flags Details
screenshot of evolution (359.79 KB, image/png)
2013-10-22 11:43 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 735953 None None None Never

  None (edit)
Description Mikhail 2013-10-22 11:42:25 EDT
Created attachment 815078 [details]
backtraces of evolution

Description of problem:
Evolution stuck when I press button "New" for create new message
Comment 1 Mikhail 2013-10-22 11:43:26 EDT
Created attachment 815079 [details]
screenshot of evolution
Comment 2 Milan Crha 2013-11-05 05:04:39 EST
Thanks for a bug report. I move this to gtk3, where the blocking call is happening (from my point of view, see the top part of the backtrace below). As something ot test, would it be possible that you had connected/mounted some external device which might cause this behaviour, like a USB (flash) disk, network place or something like that?

Thread 1 (Thread 0xb742f900 (LWP 9484)):
#0  0xb77b0424 in __kernel_vsyscall ()
#1  0x4a84b3ab in poll () from /lib/libc.so.6
#2  0x4e678f9c in g_poll () from /lib/libglib-2.0.so.0
#3  0x4e6698a0 in g_main_context_iterate.isra.22 () from /lib/libglib-2.0.so.0
#4  0x4e669dc3 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x4ec3c8a9 in g_dbus_connection_send_message_with_reply_sync () from /lib/libgio-2.0.so.0
#6  0x4ec3cc82 in g_dbus_connection_call_sync_internal () from /lib/libgio-2.0.so.0
#7  0x4ec49de0 in g_dbus_proxy_call_sync_internal () from /lib/libgio-2.0.so.0
#8  0xb6ed956c in gvfs_dbus_mount_call_query_info_sync () from /lib/libgvfscommon.so.0
#9  0xb6f169c7 in g_daemon_file_query_info () from /usr/lib/gio/modules/libgvfsdbus.so
#10 0x4ebac144 in g_file_query_info () from /lib/libgio-2.0.so.0
#11 0x4f49f4dd in update_places () from /lib/libgtk-3.so.0
#12 0x4f4a0d13 in gtk_places_sidebar_init () from /lib/libgtk-3.so.0
#13 0x4e7857de in g_type_create_instance () from /lib/libgobject-2.0.so.0
#14 0x4e767796 in g_object_new_internal () from /lib/libgobject-2.0.so.0
#15 0x4e769859 in g_object_newv () from /lib/libgobject-2.0.so.0
#16 0x4f35ef7d in _gtk_builder_construct () from /lib/libgtk-3.so.0
#17 0x4f35fef5 in builder_construct.isra.6 () from /lib/libgtk-3.so.0
#18 0x4f361fcf in end_element () from /lib/libgtk-3.so.0
#19 0x4e66db51 in g_markup_parse_context_parse () from /lib/libglib-2.0.so.0
#20 0x4f362389 in _gtk_builder_parser_parse_buffer () from /lib/libgtk-3.so.0
#21 0x4f35d449 in _gtk_builder_extend_with_template () from /lib/libgtk-3.so.0
#22 0x4f5b88cc in gtk_widget_init_template () from /lib/libgtk-3.so.0
#23 0x4f3f8414 in _gtk_file_chooser_default_init () from /lib/libgtk-3.so.0
#24 0x4e7857de in g_type_create_instance () from /lib/libgobject-2.0.so.0
#25 0x4e7672f0 in g_object_constructor () from /lib/libgobject-2.0.so.0
#26 0x4f3fdc91 in gtk_file_chooser_default_constructor () from /lib/libgtk-3.so.0
#27 0x4e767ef9 in g_object_new_internal () from /lib/libgobject-2.0.so.0
#28 0x4e769859 in g_object_newv () from /lib/libgobject-2.0.so.0
#29 0x4e769f70 in g_object_new () from /lib/libgobject-2.0.so.0
#30 0x4f3ff6f5 in _gtk_file_chooser_default_new () from /lib/libgtk-3.so.0
#31 0x4f402502 in gtk_file_chooser_widget_constructor () from /lib/libgtk-3.so.0
#32 0x4e767ef9 in g_object_new_internal () from /lib/libgobject-2.0.so.0
#33 0x4e769859 in g_object_newv () from /lib/libgobject-2.0.so.0
#34 0x4f35ef7d in _gtk_builder_construct () from /lib/libgtk-3.so.0
....
Comment 3 Milan Crha 2013-11-05 13:19:11 EST
*** Bug 1026866 has been marked as a duplicate of this bug. ***
Comment 4 Milan Crha 2013-11-05 13:22:21 EST
Note the bug #1026866 contains more information and backtraces on a gvfs issue, thus I move this to gvfs instead.
Comment 5 Ondrej Holy 2015-02-24 11:28:00 EST
It is gtk+ bug, because sync calls are used, however it should be already fixed upstream by:
https://git.gnome.org/browse/gtk%2B/commit/?id=c68fc27

Note You need to log in before you can comment on or make changes to this bug.