Bug 1022206 - ValueError: new btrfs subvols require a parent volume
ValueError: new btrfs subvols require a parent volume
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-10-22 13:15 EDT by David Lehman
Modified: 2013-11-07 00:04 EST (History)
6 users (show)

See Also:
Fixed In Version: python-blivet-0.23.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1019322
Environment:
Last Closed: 2013-11-07 00:04:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (6.77 KB, text/plain)
2013-10-31 08:55 EDT, Kamil Páral
no flags Details
program.log (25.46 KB, text/plain)
2013-10-31 08:55 EDT, Kamil Páral
no flags Details
storage.log (76.80 KB, text/plain)
2013-10-31 08:55 EDT, Kamil Páral
no flags Details
syslog (65.76 KB, text/plain)
2013-10-31 08:55 EDT, Kamil Páral
no flags Details
minimal.ks (686 bytes, text/plain)
2013-10-31 08:55 EDT, Kamil Páral
no flags Details
grub error after install (1.82 KB, image/png)
2013-11-06 04:50 EST, Kamil Páral
no flags Details

  None (edit)
Description David Lehman 2013-10-22 13:15:19 EDT
+++ This bug was initially created as a clone of Bug #1019322 +++

Description of problem:
Kickstart btrfs installation fails.


Version-Release number of selected component (if applicable):
anaconda-20.25.1-1

How reproducible:
always

Steps to Reproduce:
1. Prepare kickstart containing following lines:
zerombr
clearpart --all --initlabel
part btrfs.01 --size=6000 --ondisk=vda
part btrfs.02 --size=6000 --ondisk=vdb
btrfs none --data=0 --metadata=1 --label=rhel btrfs.01 btrfs.02
btrfs / --subvol --name=root LABEL=rhel

2. Prepare a machine with two empty unformatted discs.
3. Start the first installation use prepared kickstart. Installation is successful.
4. Start the second installation, use the same kickstart on the same machine (discs are not empty now).

Actual results:
During second kickstart installation unknown error occurs.


Expected results:
No errors. Kickstart installation should be successful.

Additional info:
Comment 1 David Lehman 2013-10-22 13:17:45 EDT
Anaconda is currently preferring existing devices when resolving device specs, which is a problem when you are removing a device with the same spec (label, in this case) as one you are creating. It should prefer whatever is in the devicetree at the time it is resolving the spec. I have a patch for this, but I have not tested it yet.
Comment 2 Adam Williamson 2013-10-23 12:43:19 EDT
Discussed at 2013-10-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-23/f20-blocker-review.2013-10-23-16.00.log.txt . As we still do not have detailed kickstart criteria, this was evaluated subjectively on its merits, and accepted as a blocker bug. We noted that it seems reasonable to apply the 'interactive' criteria to kickstart installs, so far as storage goes, and this would violate the criterion "When using the custom partitioning flow, the installer must be able to: Remove existing storage volumes and Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes" in an interactive install.
Comment 3 Fedora Update System 2013-10-25 21:10:37 EDT
anaconda-20.25.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.4-1.fc20
Comment 4 Fedora Update System 2013-10-26 14:49:16 EDT
Package anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.4-1.fc20 pykickstart-1.99.44-1.fc20 python-blivet-0.23.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20033/pykickstart-1.99.44-1.fc20,python-blivet-0.23.2-1.fc20,anaconda-20.25.4-1.fc20
then log in and leave karma (feedback).
Comment 5 Kamil Páral 2013-10-31 08:53:36 EDT
I tried to verify using reproducer in comment 0, but Anaconda presents an error during the first installation attempt:

> The following problem occurred on line 18 of the kickstart file:
> Tried to use undefined partition btrfs.01 in BTRFS volume specification

Is the kickstart sample wrong?
Comment 6 Kamil Páral 2013-10-31 08:55:11 EDT
Created attachment 817886 [details]
anaconda.log
Comment 7 Kamil Páral 2013-10-31 08:55:16 EDT
Created attachment 817887 [details]
program.log
Comment 8 Kamil Páral 2013-10-31 08:55:23 EDT
Created attachment 817888 [details]
storage.log
Comment 9 Kamil Páral 2013-10-31 08:55:28 EDT
Created attachment 817889 [details]
syslog
Comment 10 Kamil Páral 2013-10-31 08:55:34 EDT
Created attachment 817890 [details]
minimal.ks
Comment 11 David Lehman 2013-11-01 11:25:09 EDT
(In reply to Kamil Páral from comment #5)
> I tried to verify using reproducer in comment 0, but Anaconda presents an
> error during the first installation attempt:
> 
> > The following problem occurred on line 18 of the kickstart file:
> > Tried to use undefined partition btrfs.01 in BTRFS volume specification

There was an error in my original patch. I have just pushed a followup patch that fixes the problem for me.
Comment 12 Kamil Páral 2013-11-04 05:56:42 EST
David, is the patch part of anaconda 20.25.5-1.fc20 (Beta RC2)? Or is there some updates.img available? Can you provide it so that we can check the fix in advance? Thanks.
Comment 13 David Lehman 2013-11-04 10:48:08 EST
The fix is in 20.25.6-1. Here's a link to the commit/patch:

 https://git.fedorahosted.org/cgit/anaconda.git/commit/?h=f20-branch&id=79caf94fc54d8afe4e3fb991c441123795539ed6
Comment 14 Adam Williamson 2013-11-04 21:13:40 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=475300 is 20.25.6, but it doesn't appear to be in an update yet.
Comment 15 Fedora Update System 2013-11-04 22:38:57 EST
anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-11-04 23:06:50 EST
python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-20387/anaconda-20.25.6-1.fc20,python-blivet-0.23.3-1.fc20
Comment 17 Kamil Páral 2013-11-06 04:24:33 EST
Petr tried to verify this with Beta RC2 and was stopped by bug 1026825. It might be caused by the fix in comment 13.
Comment 18 Kamil Páral 2013-11-06 04:49:54 EST
I have verified that this is fixed with Beta RC4. However, during boot I see an error message 

> error: no such device: root.

right after selecting Fedora item in grub.

If I hit a key or wait a while, the boot continues as normal and the system seems to be working OK.
Comment 19 Kamil Páral 2013-11-06 04:50:18 EST
Created attachment 820264 [details]
grub error after install
Comment 20 Petr Schindler 2013-11-06 06:55:37 EST
I can confirm that problem is fixed. I have also met 'no such device' problem as Kamil in comment 18.
Comment 21 David Lehman 2013-11-06 09:15:41 EST
Please open a bug for the grub issue and include a screenshot without quiet or graphical mode (if possible) in addition to the following files:

  /var/log/anaconda/anaconda.program.log
  /boot/grub2/grub.cfg

Thanks.
Comment 22 Fedora Update System 2013-11-07 00:04:52 EST
python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.