Bug 102222 - Graphical install crash during filesystem creation - OOM killer problem
Graphical install crash during filesystem creation - OOM killer problem
Status: CLOSED DUPLICATE of bug 100453
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-12 14:47 EDT by Robert de Rooy
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2003-08-12 14:47:14 EDT
Description of problem:
I tried installing Taroon on a IBM NetVista A30p with 128MB of memory. The 
system has the Intel 845G chipset meaning that some of the system memory gets 
used for video.

During the phase of install where filesystems get created, the install 
crashed. Text mode install works fine.

Installing Severn produced a simular crash at the same point, RH9 installed 
fine.

I suspect it has to do with the amount of memory as severn 

tty1:
Running anaconda, the Red Hat Linux system installer - please wait...
Probing for video card:   Intel 845
Probing for monitor type:   IBM 6546 G52
Probing for mouse type:   Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.
The application 'mini-wm' lost its connection to the display :1.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'mini-wm' lost its connection to the display :1.0;
most likely the X server was shut down or you killed/destroyed
the application.
install existed abnormally
sending termination signals...done
dending kill signals...done
disabling swap...
        /tmp/hda3
unmounting filesystems...
        /mnt/runtime done
        /disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /tmp/ramfs done
        /mnt/source done
you may safely reboot your system

tty2:
-/bin/sh-2.05b#

tty3:
* moving (1) to step installtype
* Detected 128M of memory
* Swap attempt of 128M to 256M
* moving (1) to step partitionmethod
* moving (1) to step partitionobjinit
* moving (1) to step partitionmethodsetup
* moving (1) to step autopartition
* moving (1) to step autopartitionexecute
* moving (1) to step partitiondone
* moving (1) to step bootloadersetup
* moving (1) to step bootloader
* moving (1) to step networkdevicecheck
* moving (1) to step network
* moving (1) to step firewall
* moving (1) to step languagesupport
* moving (1) to step timezone
* moving (1) to step accounts
* moving (1) to step readcomps
* Using file://mnt/source/RedHat/base/comps.xml
* catalan-support references package aspell-ca which doesn't exist
* core references package efibootmgr which doesn't exist
* core references package elilo which doesn't exist
* moving (1) to step desktopchoices
* moving (1) to step selectlangpackages
* moving (1) to step handleX11pkgs
* moving (1) to step checkdeps
* moving (1) to step confirminstall
* moving (1) to step install
* moving (1) to step enablefilesystems

tty4:
<5>e100: eth0: Intel(R) PRO/100 Network Connection
<5>  Hardware receive checksums enabled
<5>
<6>cdrom: open failed.
<7>ISO 9660 Extensions: Microsoft Joliet Level 3
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<6>md: raid0 personality registered as nr 2
<6>md: raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4>   8regs     :  2231.200 MB/sec
<4>   32regs    :  1348.000 MB/sec
<4>   pIII_sse  :  2588.400 MB/sec
<4>   pII_mmx   :  2392.800 MB/sec
<4>   p5_mmx    :  2305.600 MB/sec
<4>raid5: using function: pIII_sse (2588.400 MB/sec)
<6>md: raid5 personality registered as nr 4
<6>Journalling Block Device driver loaded
<6>LVM version 1.0.5+(22/07/2002) module loaded
<6>parport0: PC-style at 0x378 (0x778) [PCSSP,TRISTATE]
<6>parport0: irq 7 detected
<6>kjournald started. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald started. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>Adding Swap: 257032k swap-space (priority -1)

tty5:
Setting up swapspace version 1, size = 263204 kB
mke2fs 1.33 (21-Apr-2003)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
4840192 inodes, 9679162 blocks
483958 blocks (5.00%) reserved for the super user
First data block=0
296 block groups
32768 blocks per group, 32768 fragments per group
16352 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624

Writing inode tables: 67/296


00:00.0 Host bridge: Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge 
(rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL [Brookdale-G] Chipset 
Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DB ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DB ICH4 IDE (rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB SMBus (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 01)
02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (LOM) Ethernet 
Controller (rev 81)

Version-Release number of selected component (if applicable):


How reproducible:
Every time
Comment 1 Michael Fulbright 2003-08-13 14:19:57 EDT
There was a problem with the out of memory killer in the Beta 1 kernel that
caused this issue.
Comment 2 Jeremy Katz 2003-08-18 15:59:05 EDT

*** This bug has been marked as a duplicate of 100453 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.