Bug 102223 - RPM corrupts databases
RPM corrupts databases
Status: CLOSED DUPLICATE of bug 88720
Product: Red Hat Linux Beta
Classification: Retired
Component: rpm (Show other bugs)
beta1
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-12 14:48 EDT by Alan Cox
Modified: 2006-02-21 13:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-08-12 14:48:46 EDT
Description of problem:

rpm in beta corrupts databases just like RH9 did

How reproducible:

Use beta1, do lots of rpm updates


error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested
page
not found
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested
page
not found
Comment 1 Jeff Johnson 2003-08-18 15:49:00 EDT
"corrupts" is the wrong word.

rpm through Berkeley DB uses a db environment, DB_PAGE_NOTFOUND
is an indication of cache incoherency, not "corruption".

Workaround (until someone eventually gives me an angle on a
reproducer, as I've never seen the problem) is to get rid of
the cache

    rm -f /var/lib/rpm/__db*

NEEDINFO looking for a an angle on a reproducer.




Comment 2 Alan Cox 2003-08-18 16:06:12 EDT
The rm doesnt work on the beta it seems.

As for a reproducer - it has happened on every non i686 (smell a threading bug
??) beta install I have done.
Comment 3 Jeff Johnson 2003-08-18 16:45:56 EDT
Hmmm, not bug, but possibly (ahem) unrestrained configuration
through anaconda. Might be angle here ...

Jeremy: Can you reproduce this on non-ix86? If so, can you eyeball
your (ahem) config speedups. And, at the minimum, can you nuke the
__db* files at the end of an install?
Comment 4 Matt Wilson 2003-10-21 19:46:59 EDT
we already do that:
    # rpm environment files go bye-bye
    for file in ["__db.001", "__db.002", "__db.003"]:
        try:
            os.unlink("%s/var/lib/rpm/%s" %(instPath, file))
        except Exception, e:
            log("failed to unlink /var/lib/rpm/%s: %s" %(file,e))
Comment 5 Alan Cox 2003-11-11 19:05:18 EST
So far so good in fedora 1
fingers crossed
Comment 6 Alan Cox 2003-11-11 19:21:49 EST

*** This bug has been marked as a duplicate of 88720 ***
Comment 7 Jeff Johnson 2003-12-27 00:14:24 EST
"So far so good in fc1" indicates something other than
rpm code changes have improved the change, as ther have
been no changes related to DB_PAGE_NOTFOUND that I know of.

Keep crossing those fingers, mebbe it helps.
Comment 8 Red Hat Bugzilla 2006-02-21 13:58:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.