Bug 1022377 - wireshark: harden /usr/sbin/dumpcap capabilities
wireshark: harden /usr/sbin/dumpcap capabilities
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1022378
  Show dependency treegraph
 
Reported: 2013-10-23 03:42 EDT by Florian Weimer
Modified: 2016-05-31 21:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: wireshark-1.10.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1022378 (view as bug list)
Environment:
Last Closed: 2013-11-07 23:34:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-10-23 03:42:57 EDT
wireshark-1.10.2-8 installs /usr/sbin/dumpcap with capabilities "= cap_net_admin,cap_net_raw+eip".  This should be "= cap_net_admin,cap_net_raw+ep" because these capabilities do not need to be inheritable.
Comment 1 Fedora Update System 2013-11-06 03:29:12 EST
wireshark-1.10.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.3-2.fc19
Comment 2 Fedora Update System 2013-11-06 22:40:13 EST
Package wireshark-1.10.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wireshark-1.10.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20829/wireshark-1.10.3-2.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-07 23:34:03 EST
wireshark-1.10.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.