Bug 1022378 - wireshark: harden /usr/sbin/dumpcap capabilities
wireshark: harden /usr/sbin/dumpcap capabilities
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: wireshark (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Hatina
Jiri Jaburek
:
Depends On: 1022377
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 03:44 EDT by Florian Weimer
Modified: 2016-05-31 21:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: wireshark-1.10.3-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1022377
Environment:
Last Closed: 2014-06-13 05:54:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-10-23 03:44:08 EDT
+++ This bug was initially created as a clone of Bug #1022377 +++

wireshark-1.10.2-8 installs /usr/sbin/dumpcap with capabilities "= cap_net_admin,cap_net_raw+eip".  This should be "= cap_net_admin,cap_net_raw+ep" because these capabilities do not need to be inheritable.
Comment 5 Ludek Smid 2014-06-13 05:54:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.