Bug 1022398 - file owned by more than one rpm
file owned by more than one rpm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 04:29 EDT by Parag Nemade
Modified: 2013-11-25 01:49 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.4.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 01:36:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-10-23 04:29:55 EDT
Description of problem:
rpm -qf /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.py*
maven-local-3.3.1-1.fc20.noarch
fedora-review-plugin-java-3.3.1-1.fc20.noarch
maven-local-3.3.1-1.fc20.noarch
fedora-review-plugin-java-3.3.1-1.fc20.noarch
maven-local-3.3.1-1.fc20.noarch
fedora-review-plugin-java-3.3.1-1.fc20.noarch


Version-Release number of selected component (if applicable):
javapackages-tools-3.3.1-1.fc20.noarch


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
source file owned by more than one rpm

Expected results:
should not be owned by more than one rpm

Additional info:
Comment 1 Stanislav Ochotnicky 2013-10-23 07:29:51 EDT
This was fixed upstream (8e0872d69) some time ago, except there was never F20 build with this commit. It will be sorted once F20 has latest javapackages-tools
Comment 2 Stanislav Ochotnicky 2013-10-23 10:36:51 EDT
*** Bug 1021344 has been marked as a duplicate of this bug. ***
Comment 3 Parag Nemade 2013-10-23 10:42:58 EDT
please provide me commit link to cross check this
Comment 4 Parag Nemade 2013-10-23 10:46:39 EDT
nm, at least checking out and grepping inside commit log, found the commit. dunno how to find in web git using 8e0872d69.
Comment 5 Mikolaj Izdebski 2013-10-23 10:49:41 EDT
(In reply to Parag from comment #4)
> nm, at least checking out and grepping inside commit log, found the commit.
> dunno how to find in web git using 8e0872d69.

https://github.com/mizdebsk/javapackages/commit/8e0872d69
Comment 6 Mikolaj Izdebski 2013-11-07 02:10:59 EST
Fixed in javapackages-tools-3.4.1-1
Comment 7 Mikolaj Izdebski 2013-11-25 01:36:25 EST
I believe that this bug is fixed in javapackages-tools-3.4.1-1,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=476464
Comment 8 Parag Nemade 2013-11-25 01:49:12 EST
Thank you. I see this is fixed now.

Note You need to log in before you can comment on or make changes to this bug.