This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021344 - java check warnings in fedora-review log
java check warnings in fedora-review log
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
Depends On: 1022588
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 02:48 EDT by Parag Nemade
Modified: 2014-03-07 11:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 11:10:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-10-21 02:48:30 EDT
Description of problem:
Just ran a fedora-review command and got following warnings
WARNING: Duplicate checks CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc


Version-Release number of selected component (if applicable):
fedora-review-0.5.0-1.fc20.noarch
maven-local-3.3.1-1.fc20.noarch


How reproducible:
always

Steps to Reproduce:
1.run fedora-reivew on any bugzilla review
2. observe log on commandline
3.

Actual results:
warn for java packaging check. found two packages providing same plugin

Expected results:
should not warn and maven-local should not provide any fedora-review plugin

Additional info:
Comment 1 Parag Nemade 2013-10-23 04:25:07 EDT
No response for fedora-review component, moving to maven-local.
Comment 2 Stanislav Ochotnicky 2013-10-23 10:36:51 EDT

*** This bug has been marked as a duplicate of bug 1022398 ***
Comment 3 Parag Nemade 2013-10-23 10:47:12 EDT
how can this be duplicate?
Comment 4 Parag Nemade 2013-10-23 11:01:23 EDT
I can confirm this bug still exists even after I updated javapackages-tools only using commit given in bug 1022398.

fedora-review command still showed me
WARNING: Duplicate checks CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc

we can easily observe that first set of files are from fedora-review-0.5.0-1.fc20.noarch and another set of files are from fedora-review-plugin-java-3.3.1-1.fc20.noarch
Comment 5 Mikolaj Izdebski 2013-10-23 11:08:43 EDT
It looks like fedora-review-plugin-java should conflict with older versions of fedora-review (before the split) to prevent this kind of warnings.
Comment 6 Parag Nemade 2013-10-31 04:50:42 EDT
any updates I still see following
WARNING: Duplicate checks CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckAddMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckBundledJars in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadoc in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocJPackageRequires in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckJavadocdirName in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckLocalDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNewStyleMaven in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoArch in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoOldMavenDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNoRequiresPost in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckNotJavaApplicable in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckPomInstalled in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckTestSkip in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpdateDepmap in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUpstremBuildMethod in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
WARNING: Duplicate checks CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java.pyc, CheckUseMavenpomdirMacro in /usr/lib/python2.7/site-packages/FedoraReview/plugins/java_guidelines.pyc
Comment 7 Parag Nemade 2013-10-31 09:50:10 EDT
Sochotni,
 Oh ok. All warnings are same and got repeated thrice in this bug. Sorry for that. Something went wrong while I replied above and used fedora-review command, which ate my laptop's cpu and memory to forcefully reboot the laptop. But this is really annoying for me when I use fedora-review command. 

Is there any way fedora-review command not to show any log messages at all except last one that will show failed or successful message?
Comment 8 Parag Nemade 2014-03-07 11:10:11 EST
This looks fixed already. Lets close this.

Note You need to log in before you can comment on or make changes to this bug.