Bug 1022419 - TypeError: Argument 1 does not allow None as a value
TypeError: Argument 1 does not allow None as a value
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:1d841e55f8568a2cbf0ab349e31...
: Reopened
: 1130717 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 04:58 EDT by Petr Schindler
Modified: 2014-12-10 12:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-28 09:33:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.23 MB, text/plain)
2013-10-23 04:58 EDT, Petr Schindler
no flags Details
File: anaconda.log (18.84 KB, text/plain)
2013-10-23 04:58 EDT, Petr Schindler
no flags Details
File: environ (421 bytes, text/plain)
2013-10-23 04:58 EDT, Petr Schindler
no flags Details
File: lsblk_output (2.34 KB, text/plain)
2013-10-23 04:58 EDT, Petr Schindler
no flags Details
File: nmcli_dev_list (11.52 KB, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: program.log (48.05 KB, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: storage.log (115.96 KB, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: syslog (121.12 KB, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details
File: packaging.log (910.60 KB, text/plain)
2013-10-23 04:59 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2013-10-23 04:58:35 EDT
Description of problem:
Traceback occured in custom partitioning.

Firstly I reclaimed space (in reclaim space dialog) by deleting two ext4 partitions. Then I clicked on Done. Then I changed my mind and went to custom partitioning. I expanded Fedora 17 item where swap left. Then I tried to expand Unknown item (where should be one ntfs partition). After click on Unknown anaconda took 100% cpu and after a while the traceback appeared.

My original layout was (I am not sure about numbers):
sda1 - root of F17
sda2 - home of F17 (those two I removed in reclaim space dialog)
sda3 - ntfs with windows
sda4 - swap
1.4 MB of free space

Version-Release number of selected component:
anaconda-20.25.1-1

The following was filed automatically by anaconda:
anaconda 20.25.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1831, in _populate_right_side
    self._typeCombo.set_active(type_index_map[device_type])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2465, in on_selector_clicked
    self._populate_right_side(selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2140, in _show_mountpoint
    self.on_selector_clicked(page.members[0])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2484, in on_page_clicked
    self._show_mountpoint(page=page, mountpoint=mountpointToShow)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 146, in _onExpanded
    cb(obj.get_child())
TypeError: Argument 1 does not allow None as a value

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta-TC5\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.5-302.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta-TC5
Comment 1 Petr Schindler 2013-10-23 04:58:47 EDT
Created attachment 815282 [details]
File: anaconda-tb
Comment 2 Petr Schindler 2013-10-23 04:58:51 EDT
Created attachment 815283 [details]
File: anaconda.log
Comment 3 Petr Schindler 2013-10-23 04:58:55 EDT
Created attachment 815284 [details]
File: environ
Comment 4 Petr Schindler 2013-10-23 04:58:58 EDT
Created attachment 815285 [details]
File: lsblk_output
Comment 5 Petr Schindler 2013-10-23 04:59:04 EDT
Created attachment 815286 [details]
File: nmcli_dev_list
Comment 6 Petr Schindler 2013-10-23 04:59:08 EDT
Created attachment 815287 [details]
File: os_info
Comment 7 Petr Schindler 2013-10-23 04:59:12 EDT
Created attachment 815288 [details]
File: program.log
Comment 8 Petr Schindler 2013-10-23 04:59:16 EDT
Created attachment 815289 [details]
File: storage.log
Comment 9 Petr Schindler 2013-10-23 04:59:20 EDT
Created attachment 815290 [details]
File: syslog
Comment 10 Petr Schindler 2013-10-23 04:59:23 EDT
Created attachment 815291 [details]
File: ifcfg.log
Comment 11 Petr Schindler 2013-10-23 04:59:31 EDT
Created attachment 815292 [details]
File: packaging.log
Comment 12 David Shea 2014-03-07 14:04:57 EST
Does this still occur with F20 release or rawhide?
Comment 13 Terje Røsten 2014-06-09 10:40:05 EDT
I had anaconda reporting this a duplicate of a crashing bug in the installer.

To reproduce create GPT partition tables with *gdisk*, for example
/, /var, swap, /home. Install FC19 on this system.

Then try to install of F20, while keeping /home and reformatting the rest.
Comment 14 David Shea 2014-08-05 12:31:17 EDT
(In reply to Terje Røsten from comment #13)
> I had anaconda reporting this a duplicate of a crashing bug in the installer.
> 
> To reproduce create GPT partition tables with *gdisk*, for example
> /, /var, swap, /home. Install FC19 on this system.
> 
> Then try to install of F20, while keeping /home and reformatting the rest.

Can you attach the traceback file from the crash to this bug? It would be helpful to have the exact partitioning layout that you started with. The file should be present in /tmp/anaconda-tb*
Comment 15 David Shea 2014-08-18 09:40:02 EDT
*** Bug 1130717 has been marked as a duplicate of this bug. ***
Comment 16 Terje Røsten 2014-12-10 12:51:46 EST
Not able to reproduce (so far) with F21 installs, seems fixed, thanks!

Note You need to log in before you can comment on or make changes to this bug.