Bug 1130717 - TypeError: Argument 1 does not allow None as a value
Summary: TypeError: Argument 1 does not allow None as a value
Keywords:
Status: CLOSED DUPLICATE of bug 1022419
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:13d094d15015fb2918c7a2c9cfe...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-16 20:05 UTC by billyestuvoaqui
Modified: 2014-08-18 13:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 13:40:02 UTC


Attachments (Terms of Use)
File: anaconda-tb (453.22 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: anaconda.log (13.10 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: environ (3.18 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: journalctl (214.24 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: lsblk_output (1.17 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: nmcli_dev_list (6.73 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: os_info (375 bytes, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: program.log (39.81 KB, text/plain)
2014-08-16 20:05 UTC, billyestuvoaqui
no flags Details
File: storage.log (120.55 KB, text/plain)
2014-08-16 20:06 UTC, billyestuvoaqui
no flags Details
File: ifcfg.log (16.81 KB, text/plain)
2014-08-16 20:06 UTC, billyestuvoaqui
no flags Details
File: packaging.log (3.01 KB, text/plain)
2014-08-16 20:06 UTC, billyestuvoaqui
no flags Details

Description billyestuvoaqui 2014-08-16 20:05:36 UTC
Description of problem:
Was trying to install Fedora to a USB pendrive.

Version-Release number of selected component:
anaconda-20.25.16-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.25.16-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1871, in _populate_right_side
    self._typeCombo.set_active(type_index_map[device_type])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2513, in on_selector_clicked
    self._populate_right_side(selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2186, in _show_mountpoint
    self.on_selector_clicked(page.members[0])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1027, in _do_refresh
    self._show_mountpoint(page=firstPage, mountpoint=mountpointToShow)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2589, in on_create_clicked
    self._do_refresh()
TypeError: Argument 1 does not allow None as a value

Additional info:
cmdline:        /usr/bin/python  /usr/sbin/anaconda
cmdline_file:   BOOT_IMAGE=/vmlinuz-3.15.8-200.fc20.x86_64 root=/dev/sda6 ro vconsole.font=latarcyrheb-sun16 rootfstype=ext4 zswap.enabled=1 plymouth.enable=0 LANG=es_ES.UTF-8
executable:     /usr/sbin/anaconda
hashmarkername: anaconda
kernel:         3.15.8-200.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Comment 1 billyestuvoaqui 2014-08-16 20:05:44 UTC
Created attachment 927367 [details]
File: anaconda-tb

Comment 2 billyestuvoaqui 2014-08-16 20:05:45 UTC
Created attachment 927368 [details]
File: anaconda.log

Comment 3 billyestuvoaqui 2014-08-16 20:05:47 UTC
Created attachment 927369 [details]
File: environ

Comment 4 billyestuvoaqui 2014-08-16 20:05:51 UTC
Created attachment 927370 [details]
File: journalctl

Comment 5 billyestuvoaqui 2014-08-16 20:05:52 UTC
Created attachment 927371 [details]
File: lsblk_output

Comment 6 billyestuvoaqui 2014-08-16 20:05:54 UTC
Created attachment 927372 [details]
File: nmcli_dev_list

Comment 7 billyestuvoaqui 2014-08-16 20:05:55 UTC
Created attachment 927373 [details]
File: os_info

Comment 8 billyestuvoaqui 2014-08-16 20:05:57 UTC
Created attachment 927374 [details]
File: program.log

Comment 9 billyestuvoaqui 2014-08-16 20:06:00 UTC
Created attachment 927375 [details]
File: storage.log

Comment 10 billyestuvoaqui 2014-08-16 20:06:01 UTC
Created attachment 927376 [details]
File: ifcfg.log

Comment 11 billyestuvoaqui 2014-08-16 20:06:03 UTC
Created attachment 927377 [details]
File: packaging.log

Comment 12 billyestuvoaqui 2014-08-16 20:45:30 UTC
Found the thing that caused the error. I was using a repo list, I do not know why, but it does not work with it (tryed several times).

The moment I changed to a normal repo as a source, everything went ok.

Comment 13 David Shea 2014-08-18 13:40:02 UTC

*** This bug has been marked as a duplicate of bug 1022419 ***


Note You need to log in before you can comment on or make changes to this bug.