Bug 1022558 - perl-PAR-Packer not installable, conflict with nss-tools
perl-PAR-Packer not installable, conflict with nss-tools
Status: CLOSED DUPLICATE of bug 989511
Product: Fedora
Classification: Fedora
Component: perl-PAR-Packer (Show other bugs)
20
noarch Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 10:05 EDT by Ian Morgan
Modified: 2014-11-12 03:04 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-12 03:04:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes the reported issue. (845 bytes, patch)
2014-07-22 12:39 EDT, Ian Morgan
no flags Details | Diff

  None (edit)
Description Ian Morgan 2013-10-23 10:05:08 EDT
Description of problem:
Package perl-PAR-Packer cannot be installed due to conflict with nss-tools on file /usr/share/man/man1/pp.1.gz.

The nss-tools package includes the pp man page, but the pp executable is only in the unsupported-tools directory which is not in the stock path.

I must install the the perl-PAR-Packer package, but nss-tools cannot be removed due to it's chain of dependencies being critical to the system as a whole. Yum refuses to remove it for this reason.


Version-Release number of selected component (if applicable):
nss-tools-2.15.2-1.fc19.i686


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 19 minimal
2. Attempt 'yum install perl-PAR-Packer'
3.

Actual results:
Transaction check error:
  file /usr/share/man/man1/pp/1/gz from install of perl-PAAR-Packer-1.015-1.fc19.i686 conflicts with file from package nss-tools-2.15.2-1.fc19.i686.


Expected results:
perl-PAR-Packer package installed and available for use.

Additional info:

Since the nss-tools's 'pp' program is not in the path (it is 'unsupported' apparently), it's man page need not be installed, or could be made available in /usr/share/doc/...


Workaround:
I noticed that I did not have this issue on another host recently, and upon investigation, found that it was OK on that host because yum's 'tsflags=nodocs' was enabled, so the potentially conflicting man pages were not installed at all.

There are two workarounds:

1) Install perl-PAR-Packer without the man pages (yum --setopt=tsflags=nodocs install perl-PAR-Packer)

or, since I do want those man pages,

2.a) rm -f /usr/share/man/man1/pp.1.gz
2.b) yum install perl-PAR-Packer
Comment 1 Ian Morgan 2014-07-22 12:39:45 EDT
Created attachment 919965 [details]
Patch that fixes the reported issue.

This simple patch to the SPEC file corrects the reported issue by NOT packaging the useless 1-byte pp.1.gz man page. With this change, per-PAR-Packer can be installed without conficting with nss-utils.
Comment 2 Ian Morgan 2014-07-22 12:42:34 EDT
(In reply to Ian Morgan from comment #1)
> Created attachment 919965 [details]
> Patch that fixes the reported issue.
> 
> This simple patch to the SPEC file corrects the reported issue by NOT
> packaging the useless 1-byte pp.1.gz man page. With this change,
> per-PAR-Packer can be installed without conficting with nss-utils.

FYI, the above patch is against the SPEC file for the current FC20 src rpm:
perl-PAR-Packer-1.017-1.fc20.src.rpm
Comment 3 Ian Morgan 2014-07-22 12:46:22 EDT
Modified bug to indicate that the issue is with perl-PAR-Packer instead of nss, and that's it's relevant to FC20.
Comment 4 Ian Morgan 2014-11-11 19:14:29 EST
Ping... knock-knock... Any chance of getting the above patch to the SPEC file integrated before F21?

Adding the previous SPEC file updater to the CC, in case they can help get this looked at.
Comment 5 Petr Pisar 2014-11-12 03:04:34 EST

*** This bug has been marked as a duplicate of bug 989511 ***

Note You need to log in before you can comment on or make changes to this bug.