Bug 989511 - Cannot install perl-PAR-Packer via yum
Cannot install perl-PAR-Packer via yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-PAR-Packer (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
: 1022558 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 08:10 EDT by Alexey Radkov
Modified: 2014-11-23 13:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 12:01:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Radkov 2013-07-29 08:10:19 EDT
Description of problem:

Cannot install perl-PAR-Packer via yum due to a conflict nss-tools

Version-Release number of selected component (if applicable):

Fedora 19

How reproducible:

yum install perl-PAR-Packer

(supposed that nss-tools is alraedy installed)

Actual results:

Transaction check error:
  file /usr/share/man/man1/pp.1.gz from install of perl-PAR-Packer-1.014-2.fc19.x86_64 conflicts with file from package nss-tools-3.15.1-2.fc19.x86_64

Expected results:

perl-PAR-Packer is installed
Comment 1 Petr Šabata 2013-07-30 05:15:52 EDT
Both packages provide the 'pp' binary, however nss-tools' one isn't in the standard path.

CC'ing the nss-tools' pp author and maintainer.
Comment 2 Elio Maldonado Batiz 2013-08-26 10:47:13 EDT
(In reply to Petr Šabata from comment #1)
> Both packages provide the 'pp' binary, however nss-tools' one isn't in the
> standard path.
> 
> CC'ing the nss-tools' pp author and maintainer.

perl-PAR-Packer cannot install because it tries to install what looks like an empty man page for its pp tool.
Please see https://bugzilla.redhat.com/show_bug.cgi?id=987189#c1
Comment 3 Petr Šabata 2013-08-27 12:01:43 EDT
I've responded to bug #987189.

The conflict isn't caused by PAR::Packer; that the manpage is empty is a different issue.  Closing as NOTABUG; this should be resolved in #987189.
Comment 4 Petr Pisar 2014-11-12 03:04:34 EST
*** Bug 1022558 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.