Bug 1022608 - After switching from full-screen using Shift-F11, arbitrary resolution doesn't work
Summary: After switching from full-screen using Shift-F11, arbitrary resolution doesn'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.3.0
Hardware: Unspecified
OS: Windows
unspecified
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Marc-Andre Lureau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1181289
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-23 15:35 UTC by Milan Barta
Modified: 2016-03-09 20:04 UTC (History)
10 users (show)

Fixed In Version: mingw-spice-gtk-0.26-4.el7ev mingw-virt-viewer-2.0-2.el7ev rhevm-spice-client 3.6-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1146997 1146998 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:04:17 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0377 0 normal SHIPPED_LIVE rhevm-spice-client bug fix and enhancement update 2016-03-10 00:39:05 UTC

Description Milan Barta 2013-10-23 15:35:13 UTC
Description of problem:
After running virt-viewer from RHEVM User Portal in full-screen mode and switching to window mode using the Shift-F11 keyboard shortcut, the guest resolution can no longer be changed by resizing the remote-viewer window.

Version-Release number of selected component (if applicable):
RHEVM 3.3 is19
Client: Windows 7 32bit

mingw-virt-viewer-0.5.6-8.el6_4


How reproducible:
Always

Steps to Reproduce:
1. Set Open in Full Screen in Console options of VM
2. Open the console -> VM opens in full screen mode
3. Use Shift-F11 to switch to window mode

Actual results:
The guest resolution is not appropriately changed to match the window size. Further manual changes of the remote-viewer window are ignored as well.

Expected results:
Guest resolution changes to match the window dimensions.

Additional info:
Using the button at the top of the screen to exit from full screen mode works fine. The bug only occurs when keyboard shortcut Shift-F11 is used.

Comment 1 Marc-Andre Lureau 2013-10-29 13:33:03 UTC
I can reproduce, but it doesn't always happen. If I leave fullscreen with the button once, then the keyboard shortcut works. Weird..

Comment 2 Marc-Andre Lureau 2013-10-29 19:04:53 UTC
the bug is fixed in upstream, where the fullscreen/unfullscreen logic has been modified. I think we should wait for next rebase.

Comment 3 Jonathon Jongsma 2014-05-30 22:02:13 UTC
rebase proposed for 3.5 (Bug 1103366)

Comment 5 Marian Krcmarik 2014-09-12 09:31:44 UTC
I still can reproduced the bug in following steps:

1. Set Open in Full Screen in Console options of VM
2. Open the console -> VM opens in full screen mode
3. Use Shift-F11 to switch to window mode -> resolution is adjusted.
4. Use Shift-F11 to switch to full-screen mode -> resolution is not adjusted.

It works properly when using virt-viewer full-screen button instead of keyboard shortcut.

Comment 6 Jonathon Jongsma 2014-09-25 16:04:59 UTC
Posted a patch: https://www.redhat.com/archives/virt-tools-list/2014-September/msg00233.html

Comment 9 Uri Lublin 2015-06-15 23:19:32 UTC
Rebase done -- moving to MODIFIED

Comment 13 Dayle Parker 2016-03-04 03:05:08 UTC
Changed doc_text field to - due to "no doc required" message.

Comment 15 errata-xmlrpc 2016-03-09 20:04:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0377.html


Note You need to log in before you can comment on or make changes to this bug.