Bug 1022614 - Geo-rep does not fail over as required in RHS 2.1
Geo-rep does not fail over as required in RHS 2.1
Status: CLOSED DUPLICATE of bug 1022518
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 11:42 EDT by Harold Miller
Modified: 2013-10-23 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 11:56:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harold Miller 2013-10-23 11:42:24 EDT
Description of problem: When node fails geo-rep is not failing over gracefully. See "defunct" status. And when you try to stop the geo-rep it doesn't work as well.


Version-Release number of selected component (if applicable): RHS 2.1

Actual results:
[deploy@pprddapglu13400 ~]$ sudo gluster volume geo-replication dp-vol ssh://pprddapglu13300.example.net::dp-vol1 status
NODE                             MASTER    SLAVE                                           HEALTH     UPTIME
-----------------------------------------------------------------------------------------------------------------
pprddapglu13400.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:49:50
pprddapglu13404.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    defunct    N/A
pprddapglu13418.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13409.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13423.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13405.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13414.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13422.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13421.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13419..example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13427.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13408.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13410.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:49:48
pprddapglu13407.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13406.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    defunct    N/A
pprddapglu13426.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    defunct    N/A
pprddapglu13412.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13415.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13425.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13417.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13416.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:49:49
pprddapglu13401.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13402.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13424.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13420.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13403.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13411.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
pprddapglu13413.example.net    dp-vol    ssh://pprddapglu13300.example.net::dp-vol1    Stable     07:58:14
[deploy@pprddapglu13400 ~]$ sudo gluster volume geo-replication dp-vol ssh://pprddapglu13300.example.net::dp-vol1 stop
Staging failed on pprddapglu13406.ie.example.net. Error: geo-replication session b/w dp-vol & ssh://pprddapglu13300.example.net::dp-vol1 is not running on this node.
Staging failed on pprddapglu13404.example.net. Error: geo-replication session b/w dp-vol & ssh://pprddapglu13300.example.net::dp-vol1 is not running on this node.
Staging failed on pprddapglu13426.example.net. Error: geo-replication session b/w dp-vol & ssh://pprddapglu13300.example.net::dp-vol1 is not running on this node.
geo-replication command failed
Comment 1 Harshavardhana 2013-10-23 11:56:53 EDT

*** This bug has been marked as a duplicate of bug 1022518 ***

Note You need to log in before you can comment on or make changes to this bug.