Bug 1022518 - Dist-geo-rep : When node goes down and come back in master cluster, that particular session will be defunct.
Dist-geo-rep : When node goes down and come back in master cluster, that part...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Avra Sengupta
Vijaykumar Koppad
: ZStream
: 1022614 (view as bug list)
Depends On:
Blocks: 1022593
  Show dependency treegraph
 
Reported: 2013-10-23 09:01 EDT by Vijaykumar Koppad
Modified: 2014-12-23 01:55 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.37rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, if a node in master cluster of geo-replication got rebooted, it would cause the session to become defunct, causing the whole setup not to work properly. With this update, the issue is handled properly, so now, the node reboots are not causing any defunct processes.
Story Points: ---
Clone Of:
: 1022593 (view as bug list)
Environment:
Last Closed: 2013-11-27 10:43:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-10-23 09:01:47 EDT
Description of problem:When node goes down and come back in master cluster, that particular session will be defunct. This is actually result not bringing back the monitor process when the node come back . 


Version-Release number of selected component (if applicable):glusterfs-3.4.0.33rhs-1.el6rhs.x86_64


How reproducible: happens everytime,


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave. 
2.bring down one of the node from master cluster and bring it back
3.Check the geo-rep status.

Actual results: Particular geo-rep session goes defunct 


Expected results: When node  goes down and comes back, it should be restarted properly 


Additional info:
Comment 1 M S Vishwanath Bhat 2013-10-23 09:06:54 EDT
Actually for me it went to "faulty" state also. Out of the two times I did this test session went to "faulty" once and "defunct" other time.
Comment 3 Harshavardhana 2013-10-23 11:56:53 EDT
*** Bug 1022614 has been marked as a duplicate of this bug. ***
Comment 4 Avra Sengupta 2013-10-24 09:14:20 EDT
Patch sent upstream at http://review.gluster.org/6130
Comment 5 Vijaykumar Koppad 2013-10-31 09:18:45 EDT
verified on glusterfs-3.4.0.37rhs-1
Comment 7 errata-xmlrpc 2013-11-27 10:43:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.