Bug 1022628 - Unable to build from source on aarch64 (probably also other than x86-64)
Unable to build from source on aarch64 (probably also other than x86-64)
Status: CLOSED DUPLICATE of bug 1009741
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2013-10-23 12:05 EDT by Marcin Juszkiewicz
Modified: 2013-11-04 12:05 EST (History)
2 users (show)

See Also:
Fixed In Version: hunspell-en-0.20121024-6.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 06:31:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for a bug (342 bytes, patch)
2013-10-23 12:05 EDT, Marcin Juszkiewicz
no flags Details | Diff

  None (edit)
Description Marcin Juszkiewicz 2013-10-23 12:05:11 EDT
Created attachment 815466 [details]
fix for a bug

Description of problem:

hunspell-en source contains two x86-64 binaries which are used during build. Due to that any build on other architecture (aarch64 in this case) fails.

Version-Release number of selected component (if applicable):

0.20121024-5

How reproducible:

always

Steps to Reproduce:
1. grab arm or aarch64 system
2. rebuild package

Actual results:

./make-aspell-dict
base
deaccent
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 49: src/deaccent: cannot execute binary file

Expected results:

package build

Additional info:
Comment 1 Caolan McNamara 2013-10-24 06:31:50 EDT
Isn't this a duplicate of bug #1009741 and actually already fixed in 0.20121024-5 ? I don't see scowl/src/deaccent scowl/src/find-accented in 0.20121024-5 but I do see them in 0.20121024-4

*** This bug has been marked as a duplicate of bug 1009741 ***
Comment 2 Caolan McNamara 2013-10-24 07:11:02 EDT
Built a hunspell-en-0.20121024-6.fc21/fc20 in case some problem with that fix not getting into all branches

Note You need to log in before you can comment on or make changes to this bug.