Bug 1022738 - LUKSError: luks device not configured
LUKSError: luks device not configured
Status: CLOSED DUPLICATE of bug 983099
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:170a8275afdc56b5a97eb945533...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 18:09 EDT by Mukundan Ragavan
Modified: 2014-12-08 19:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 17:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (300.51 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: anaconda.log (7.17 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: environ (404 bytes, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: lsblk_output (2.67 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: nmcli_dev_list (4.36 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: program.log (40.17 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: storage.log (134.53 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: syslog (66.20 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details
File: packaging.log (12.35 KB, text/plain)
2013-10-23 18:09 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2013-10-23 18:09:21 EDT
Version-Release number of selected component:
anaconda-20.25.1-1

The following was filed automatically by anaconda:
anaconda 20.25.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 164, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1161, in handleUdevLUKSFormat
    device.format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1705, in handleUdevDeviceFormat
    self.handleUdevLUKSFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1075, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1936, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1880, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 417, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 438, in _doExecute
    self.storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in wait
    self.raise_error(name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 869, in refresh
    threadMgr.wait(thread_name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 429, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
LUKSError: luks device not configured

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta-TC5\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.5-302.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta-TC5
Comment 1 Mukundan Ragavan 2013-10-23 18:09:25 EDT
Created attachment 815575 [details]
File: anaconda-tb
Comment 2 Mukundan Ragavan 2013-10-23 18:09:29 EDT
Created attachment 815576 [details]
File: anaconda.log
Comment 3 Mukundan Ragavan 2013-10-23 18:09:32 EDT
Created attachment 815577 [details]
File: environ
Comment 4 Mukundan Ragavan 2013-10-23 18:09:35 EDT
Created attachment 815578 [details]
File: lsblk_output
Comment 5 Mukundan Ragavan 2013-10-23 18:09:38 EDT
Created attachment 815579 [details]
File: nmcli_dev_list
Comment 6 Mukundan Ragavan 2013-10-23 18:09:41 EDT
Created attachment 815580 [details]
File: os_info
Comment 7 Mukundan Ragavan 2013-10-23 18:09:44 EDT
Created attachment 815581 [details]
File: program.log
Comment 8 Mukundan Ragavan 2013-10-23 18:09:47 EDT
Created attachment 815582 [details]
File: storage.log
Comment 9 Mukundan Ragavan 2013-10-23 18:09:50 EDT
Created attachment 815583 [details]
File: syslog
Comment 10 Mukundan Ragavan 2013-10-23 18:09:54 EDT
Created attachment 815584 [details]
File: ifcfg.log
Comment 11 Mukundan Ragavan 2013-10-23 18:09:57 EDT
Created attachment 815585 [details]
File: packaging.log
Comment 12 David Shea 2014-12-08 17:37:40 EST
Does this issue still occur in Fedora 21? Can you provide steps to reproduce this issue?
Comment 13 David Shea 2014-12-08 17:45:33 EST

*** This bug has been marked as a duplicate of bug 983099 ***
Comment 14 Mukundan Ragavan 2014-12-08 19:00:18 EST
Actually no. It's been a very long time since I saw this. Closing this is best.

Note You need to log in before you can comment on or make changes to this bug.