Bug 983099 - LUKSError: luks device not configured
LUKSError: luks device not configured
Status: CLOSED DUPLICATE of bug 1008732
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:d920b86ddd246ddb417eb314c9a...
:
: 984309 997535 1022738 1031923 1035498 1044787 1046911 1101163 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 09:50 EDT by Jakub Dorňák
Modified: 2016-11-30 19:57 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-06 20:06:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (242.52 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: environ (535 bytes, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: lsblk_output (3.57 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: messages (427.71 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: nmcli_dev_list (13.13 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: program.log (146.88 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: ifcfg.log (1.39 KB, text/plain)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: anaconda-tb (1.97 MB, application/octet-stream)
2013-07-10 09:50 EDT, Jakub Dorňák
no flags Details
File: storage.log (1.18 MB, text/plain)
2013-07-10 09:51 EDT, Jakub Dorňák
no flags Details
Log from the error window (1.56 MB, text/plain)
2013-10-09 14:51 EDT, szebenyib
no flags Details

  None (edit)
Description Jakub Dorňák 2013-07-10 09:50:03 EDT
Description of problem:
I have just resumed the installation, where it failed during the previous run. (see the bug #983095)

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 163, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 840, in setupParents
    _format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 526, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LUKSError: luks device not configured

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Jakub Dorňák 2013-07-10 09:50:08 EDT
Created attachment 771621 [details]
File: anaconda.log
Comment 2 Jakub Dorňák 2013-07-10 09:50:13 EDT
Created attachment 771622 [details]
File: environ
Comment 3 Jakub Dorňák 2013-07-10 09:50:17 EDT
Created attachment 771623 [details]
File: lsblk_output
Comment 4 Jakub Dorňák 2013-07-10 09:50:23 EDT
Created attachment 771624 [details]
File: messages
Comment 5 Jakub Dorňák 2013-07-10 09:50:28 EDT
Created attachment 771625 [details]
File: nmcli_dev_list
Comment 6 Jakub Dorňák 2013-07-10 09:50:32 EDT
Created attachment 771626 [details]
File: os_info
Comment 7 Jakub Dorňák 2013-07-10 09:50:36 EDT
Created attachment 771627 [details]
File: program.log
Comment 8 Jakub Dorňák 2013-07-10 09:50:43 EDT
Created attachment 771628 [details]
File: ifcfg.log
Comment 9 Jakub Dorňák 2013-07-10 09:50:55 EDT
Created attachment 771629 [details]
File: anaconda-tb
Comment 10 Jakub Dorňák 2013-07-10 09:51:06 EDT
Created attachment 771630 [details]
File: storage.log
Comment 11 David Shea 2013-08-08 09:48:31 EDT
*** Bug 984309 has been marked as a duplicate of this bug. ***
Comment 12 James H (Jim) Bills 2013-09-26 20:54:23 EDT
On the Installation Destination screen, with the hard drive selected, I pressed the <Done> button. On the INSTALATION OPTIONS dialog box I clicked the <Custom Partitioning> button. On the Manual Partitioning screen I expanded the Unknown in the device list, I clicked on Encryoted LUKS (/dev/sda6), entered the passphase, and clicked the <unlock> button. The encrypted partition disappeared. I pressed the <Reload storage configuration from disk> button at the bottom of the device list. After the device list refreshed the logical volumes on the disk on the encrypted volume appeared. I the selected the volumevg-root logical volume to be reformatted as an ext4 filesystem, mounted on /. I selected the unencrypted partition (/dev/sda5) to be reformatted as an ext4 filesystem, mounted on /boot. Finally, I selected the volumevg-swap logical volume to be the reformatted the swap partition. I pressed the <Done> button and a confirmation dialog box and clicked to the <accept changes> button. I returned to the previous screen and pressed the <Begin Installation> button. On the Configuration screen, I waited while the setting up the installation process bar expanded.  After a few second an Unknown error has occurred dialog box appear and I select the <Report Bug..,> button.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         LUKSError: luks device not configured
release:        Cannot get release name.
version:        19
Comment 13 szebenyib 2013-10-09 10:58:09 EDT
The same has happened here: existing LUKS on which an LVM group resides.
I tried to use the install media as of Fedora 19 as of today. Chosen /boot partition resides on the non-LUKS part of the disk. I have specified separate /var /home /root partitions which already exist on the LUKS+LVM part of the disk. Upon trying to install the same happens to me.
Comment 14 szebenyib 2013-10-09 14:51:39 EDT
Created attachment 810106 [details]
Log from the error window
Comment 15 James H (Jim) Bills 2013-10-09 16:09:55 EDT
I have RESOLVED this problem. I had previous attempted a fedup upgrade to Fedora 19 when I encountered the problem described in Comment 12. To resolve this problem, I booted from the Fedora 19 x86_64 DVD and followed the procedure in Comment 12 to the point where the Comment say ``The encrypted partition disappeared.''  This time I the noticed, without pressing the <Reload storage configuration from disk> button as described in 12, the ``Fedora Linux 19 for x86_64'' below the ``new Fedora 19 Installation'' on the side bar.  I clicked on the triangle beside the ``Fedora Linux 19...'' to expand it.  Inside were all of the existing partitions from my upgraded system.  On the existing /, and /boot I set the the appropriate mount point and clicked the format check box. I also chose to format the existing swap. This moved the /, boot and swap partitions out of the ``Fedora Linux 19...'' group to the ``New Fedora 19...'' group.  I chose to leave the my /home partition under the the ``Fedora 19...'' group, handling its mounting after I re-installed Fedora 19. I clicked the <Done> button and a confirmation dialog box and clicked to the <accept changes> button. I returned to the previous screen and pressed the <Begin Installation> button. On the Configuration screen, I was able to enter the root password and the user information followed by successful re-installation of Fedora 19.

For emphasis: the failure describe in Comment 12 appeared from not removing the partitions from the existing upgraded installation.  Once I realized what the sidebar was showing me, I was successfully performed the re-installation described above.
Comment 16 Lene Jensen 2013-10-09 16:22:38 EDT
I was installing, and had just set the root password, and clicked Done.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/Fedora-Live-Desktop-x86_64-19-1/isolinux/vmlinuz0 root=live:LABEL=Multi-Boot rootfstype=auto ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0 live_dir=/Fedora-Live-Desktop-x86_64-19-1/LiveOS/
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         LUKSError: luks device not configured
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 17 szebenyib 2013-10-09 16:44:01 EDT
(In reply to szebenyib from comment #13)
> The same has happened here: existing LUKS on which an LVM group resides.
> I tried to use the install media as of Fedora 19 as of today. Chosen /boot
> partition resides on the non-LUKS part of the disk. I have specified
> separate /var /home /root partitions which already exist on the LUKS+LVM
> part of the disk. Upon trying to install the same happens to me.

To further clarify it:
I had an LVM@LUKS config with 7 partitions on it:
1 home for arch & 1 home for ubuntu
1 root for arch & 1 root for ubuntu
1 var  for arch & 1 var  for ubuntu
1 swap
In the non-luks area I had 150MB space for a /boot partition.

I have chosen to reformat the ubuntu ones and use their space to install fedora. I chose to remove the ubuntu variants and format their space as ext2-boot, ext4-root and home, reiserfs-var. There was no upgrade from earlier fedora versions.
Comment 18 Scott A. Kuehne 2013-12-09 05:48:51 EST
I was setting the root password during the install process.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-i686-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.i686
package:        anaconda-19.30.13-1.fc19.i686
packaging.log:  
product:        Fedora
reason:         LUKSError: luks device not configured
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 19 David Shea 2014-12-08 17:45:33 EST
*** Bug 1022738 has been marked as a duplicate of this bug. ***
Comment 20 David Shea 2014-12-08 17:45:36 EST
*** Bug 1031923 has been marked as a duplicate of this bug. ***
Comment 21 David Shea 2014-12-08 17:46:02 EST
*** Bug 997535 has been marked as a duplicate of this bug. ***
Comment 22 David Shea 2014-12-08 17:46:19 EST
*** Bug 1101163 has been marked as a duplicate of this bug. ***
Comment 23 David Shea 2014-12-08 17:46:21 EST
*** Bug 1046911 has been marked as a duplicate of this bug. ***
Comment 24 David Shea 2014-12-08 17:46:23 EST
*** Bug 1044787 has been marked as a duplicate of this bug. ***
Comment 25 David Shea 2014-12-08 17:47:06 EST
*** Bug 1035498 has been marked as a duplicate of this bug. ***
Comment 26 Brian Lane 2015-01-06 20:06:21 EST

*** This bug has been marked as a duplicate of bug 1008732 ***

Note You need to log in before you can comment on or make changes to this bug.