Bug 1022754 - unable to initialize libusb on ppc64
unable to initialize libusb on ppc64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.7.0
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
William Gomeringer
:
: 1048650 (view as bug list)
Depends On:
Blocks: 1016295
  Show dependency treegraph
 
Reported: 2013-10-23 20:10 EDT by Brian Brock
Modified: 2016-07-05 13:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: hwcert-client 1.7.0-20131219
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 13:52:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch tests/usb/usb.py (790 bytes, patch)
2013-12-17 05:20 EST, Dong Zhu
gnichols: review-
Details | Diff

  None (edit)
Description Brian Brock 2013-10-23 20:10:25 EDT
Description of problem:
ppc64 print "unable to initialize libusb" prior to any other output

Version-Release number of selected component (if applicable):
1.7.0

How reproducible:
every execution

Steps to Reproduce:
1. run "hwcert-backend plan"
2. run "hwcert-backend run -t core"
3.

Actual results:
unable to initialize libusb: -99
unable to initialize libusb: -99
unable to initialize libusb: -99
Set server to ...for  1 test(s)

Running the following tests:
core
info


Expected results:
same output without libusb error message
Comment 9 Dong Zhu 2013-12-17 05:20:59 EST
Created attachment 837624 [details]
patch tests/usb/usb.py
Comment 10 Greg Nichols 2013-12-17 13:00:26 EST
Comment on attachment 837624 [details]
patch tests/usb/usb.py

This patch really won't help.  It will just add "failed" message if lsusb doesn't find any devices (including failure).
Comment 16 Greg Nichols 2014-01-09 10:01:29 EST
*** Bug 1048650 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.