Bug 1022793 - we shouldn't ship nginx agent
we shouldn't ship nginx agent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: David Vossel
Cluster QE
: Reopened, ZStream
Depends On:
Blocks: 1032776 1032778
  Show dependency treegraph
 
Reported: 2013-10-24 00:51 EDT by Andrew Beekhof
Modified: 2014-10-14 00:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-41.el6
Doc Type: Bug Fix
Doc Text:
The following agents were shipped in error, and thus have now been dropped: nginx, rsyslog, mysql-proxy, tomcat, and slapd.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:59:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 549053 None None None Never

  None (edit)
Description Andrew Beekhof 2013-10-24 00:51:40 EDT
Description of problem:

we ship the nginx agent but not nginx itself

Version-Release number of selected component (if applicable):

Name        : resource-agents              Relocations: (not relocatable)
Version     : 3.9.2                             Vendor: Red Hat, Inc.
Release     : 21.el6_4.8                    Build Date: Mon 07 Oct 2013 16:13:15 EDT
Comment 2 Andrew Beekhof 2013-10-24 03:13:21 EDT
Also the rsyslog agent doesnt do anything useful and should be dropped
Comment 3 RHEL Product and Program Management 2013-10-27 03:24:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 David Vossel 2013-10-28 09:33:05 EDT
(In reply to Andrew Beekhof from comment #2)
> Also the rsyslog agent doesnt do anything useful and should be dropped

mysql-proxy.  We don't ship that apparently. It should be dropped as well.
Comment 5 David Vossel 2013-11-18 14:14:53 EST
also, tomcat and slapd until they are fixed.

The drop list.

nginx
rsyslog
mysql-proxy
tomcat
slapd
Comment 6 David Vossel 2013-11-20 14:37:38 EST
(In reply to David Vossel from comment #5)
> also, tomcat and slapd until they are fixed.
> 
> The drop list.
> 
> nginx
> rsyslog
> mysql-proxy
> tomcat
> slapd

There is no resource-agents project patch associated with this change.  This is a spec file change that adds agents in the above list to a the excludes list.
Comment 14 michal novacek 2014-07-29 08:56:19 EDT
I have verified that nginx, rsyslog, mysql-proxy and slapd has been dropped from resource-agents-3.9.5-11.el6.x86_64.

Tomcat got fixed and re-added (bz1022792).

-----

# rpm -q resource-agents
resource-agents-3.9.5-11.el6.x86_64

# rpm -ql resource-agents | grep 'nginx\|rsyslog\|mysql-proxy\|slapd'
# echo $?
1
Comment 15 errata-xmlrpc 2014-10-14 00:59:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1428.html

Note You need to log in before you can comment on or make changes to this bug.