Bug 1022969 - groovy should depend on jline1 in rawhide
groovy should depend on jline1 in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: groovy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 1022908
Blocks: 1022897
  Show dependency treegraph
 
Reported: 2013-10-24 07:38 EDT by Severin Gehwolf
Modified: 2013-10-25 06:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.8.9-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 06:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-10-24 07:38:44 EDT
This bug is filed because groovy in rawhide lists jline as BR in its spec file. Please see bug 1022897 for more info. Note that jline will become version 2.x there. It would be strongly preferred if groovy could be made to work with jline 2.x. If this is not possible please change the BR to jline1 (see bug 1022908).

Thanks for your cooperation!
Comment 1 Severin Gehwolf 2013-10-24 07:40:30 EDT
Requires of groovy should be changed as well. Feel free to close this bug once groovy has been updated in rawhide.
Comment 2 Mikolaj Izdebski 2013-10-24 08:07:28 EDT
Fixed in groovy-1.8.9-6
Comment 3 Mikolaj Izdebski 2013-10-25 06:35:20 EDT
I believe that this bug is fixed in groovy-1.8.9-6,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=473705

Note You need to log in before you can comment on or make changes to this bug.