Bug 1022897 - jline2 should *no* longer be a compat package
jline2 should *no* longer be a compat package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Severin Gehwolf
: Tracking
Depends On: 1022909 1022915 1022965 1022969 1022971 1023004 1023006 1023011 1023015 1023018 1023021 1023023 1023024 1024416
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 05:03 EDT by Severin Gehwolf
Modified: 2014-08-09 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 06:53:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-10-24 05:03:18 EDT
Currently jline2 is the newest packaged version of jline in Fedora. However, it's also a compatibility package which is wrong. Instead, the jline package should be the newest available package and the current jline moved to a jline1 compat package. once jline has become what jline2 now is (minus compat), jline2 should get retired in rawhide.

Packages currently requiring (R/BR) jline2 should require jline instead. Packages which desperately need jline1 should move to R/BR jline1 instead.
Comment 1 Severin Gehwolf 2014-06-10 06:53:39 EDT
Package jline in rawhide has been version 2.x for a while now. Closing as fixed. Package leiningen FTBFS, but seems to be unrelated to this change (it compiled fine with 2.x jline).

Note You need to log in before you can comment on or make changes to this bug.