Bug 1023017 - Restore ECC support in Erlang's crypto library
Summary: Restore ECC support in Erlang's crypto library
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: erlang   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ecc 1086146
TreeView+ depends on / blocked
 
Reported: 2013-10-24 13:03 UTC by Peter Lemenkov
Modified: 2014-08-27 18:57 UTC (History)
8 users (show)

Fixed In Version: erlang-17.2.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-27 18:57:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Lemenkov 2013-10-24 13:03:12 UTC
Right now ECC is disabled explicitly since it looks like Erlang's crypto library assumes that it's either available fully or not. We've just enabled few ECC curves so this confuses erlang-crypto and leads to a startup issue like this:


=ERROR REPORT==== 24-Oct-2013::16:30:48 ===
Unable to load crypto library. Failed with error:
"load_failed, Failed to load NIF library: '/usr/lib64/erlang/lib/crypto-3.1/priv/lib/crypto.so: undefined symbol: EC_GROUP_new_curve_GF2m'"
OpenSSL might not be installed on this system.

We should patch crypto module to provide available ECC bits instead of disabling it completely.

Comment 1 Travis Paul 2013-11-18 03:19:32 UTC
I was seeing the startup errors you mentioned above and I seemed to have resolved them by installing the openssl-libs package. Would it be possible to add openssl-libs as an erlang-crypto requirement until the patching you mention is complete?

Comment 2 Konrad Gądek 2013-12-13 15:50:58 UTC
What's the status of this one?

Comment 3 Peter Lemenkov 2013-12-27 09:41:22 UTC
(In reply to Konrad Gądek from comment #2)
> What's the status of this one?

Hello All!
Despite of Christmas and the rest of the Holidays we're working on it - stay tuned!

Comment 4 Eiichi Tsukata 2014-01-16 12:19:16 UTC
It seems that the following commit fix the problem:
https://github.com/RoadRunnr/otp/commit/8837c1be2ba8a3c123df3f5a87003daa9aac6539

It will be merged to the otp upstream soon.


Note You need to log in before you can comment on or make changes to this bug.