Bug 1086146 - Better Erlang Support
Summary: Better Erlang Support
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact:
Yoana Ruseva
URL:
Whiteboard: ChangeAcceptedF21 SelfContainedChange
Keywords:
Depends On: 784693 1023017 1083637 1087229 1103524 1161922
Blocks: 1089941 1096606
TreeView+ depends on / blocked
 
Reported: 2014-04-10 08:42 UTC by Jaroslav Reznik
Modified: 2014-12-08 15:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 15:22:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

Description Jaroslav Reznik 2014-04-10 08:42:25 UTC
This is a tracking bug for Change: Better Erlang Support
For more details, see: http://fedoraproject.org//wiki/Changes/BetterErlangSupport

Update Erlang/OTP to R17, and improve Erlang integration with the rest of Fedora.

Comment 1 Jaroslav Reznik 2014-07-04 10:43:41 UTC
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule

Comment 2 Peter Lemenkov 2014-07-07 12:50:55 UTC
Moving forward to F-21.

Comment 3 Yoana Ruseva 2014-08-21 10:00:35 UTC
Hi Peter and Sam,

I wrote a part of the Development Beat for Fedora 21, which includes notes on the changes in the Erlang language. Could you please have a look at the text and see if it's correct or whether you'd like to add anything:

https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/Devel

(under Erlang/OTP)

Thanks a lot!

Yoana

Comment 4 Peter Lemenkov 2014-09-10 10:38:40 UTC
(In reply to Yoana Ruseva from comment #3)
> Hi Peter and Sam,
> 
> I wrote a part of the Development Beat for Fedora 21, which includes notes
> on the changes in the Erlang language. Could you please have a look at the
> text and see if it's correct or whether you'd like to add anything:
> 
> https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/
> Devel
> 
> (under Erlang/OTP)
> 
> Thanks a lot!
> 
> Yoana

1. I'd rather use link to Erlang 17.0 rather than to 17.1 which is
just a bugfix release to 17.0. Or even better both of them:

* http://www.erlang.org/news/73 - 17.0
* http://www.erlang.org/news/77 - 17.1 (bugfixes and improvements)

We actually updated Erlang up to 17.2.2 version (still not released
officially but Fedora is about being first!).

2. This part still not finished - "centralized unified logging from
all Erlang applications". I'm afraid we didn't made it to release.  So
I'd rather remove it.

3. "rpmlint messages regarding..." - this one is related to a
packaging process. I'd remove it since it's just unnecessary detail.

Otherwise looks good.

Comment 5 Yoana Ruseva 2014-09-10 11:43:32 UTC
Thanks a lot, removed these two points and corrected the link to point to Erlang 17.0:

https://fedoraproject.org/wiki/Documentation_Development_Beat#Erlang.2FOTP

Comment 6 Jaroslav Reznik 2014-10-07 12:23:50 UTC
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule

Comment 7 Jaroslav Reznik 2014-10-13 14:36:46 UTC
Peter, any updates? The change deadline is tomorrow. Based on comment #4, it seems like we have correct RN documentation now. May I move the Change to ON_QA?

Comment 8 Peter Lemenkov 2014-10-13 17:26:29 UTC
(In reply to Jaroslav Reznik from comment #7)
> Peter, any updates? The change deadline is tomorrow. Based on comment #4, it
> seems like we have correct RN documentation now. May I move the Change to
> ON_QA?

Hello Jaroslav!
Yes, you may change it to ON_QA now. I still working on it (I plan to roll one more update - up to recently released ver. 17.3) and on Packaging Guidelines but overall it's ready.


Note You need to log in before you can comment on or make changes to this bug.