Bug 1023018 - [heads-up] Upcoming jline change in rawhide
[heads-up] Upcoming jline change in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bsh (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Srb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1022897
  Show dependency treegraph
 
Reported: 2013-10-24 09:05 EDT by Severin Gehwolf
Modified: 2013-10-30 06:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: bsh-1.3.0-28.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 06:08:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-10-24 09:05:35 EDT
This bug is filed because bsh-utils in rawhide lists jline as R/BR in its spec file. Please see bug 1022897 for more info. Note that jline will become version 2.x. It would be strongly preferred if bsh-utils could be made to work with jline 2.x. If this is not possible please change the R/BR to jline1 (see bug 1022908). Note that jline1 might get retired in a future version of Fedora. As such jline 2.x should be used if at all possible.

Thanks for your cooperation!
Comment 1 Severin Gehwolf 2013-10-24 09:06:21 EDT
Please close this bug once bsh has been updated in rawhide.
Comment 2 Michal Srb 2013-10-24 09:46:38 EDT
bsh doesn't work with jline2. I will try to port it to new API.
Comment 3 Marek Goldmann 2013-10-30 04:45:15 EDT
Michal, you can use jline1 package if this works for you.
Comment 4 Michal Srb 2013-10-30 04:48:09 EDT
jline1 works and I will switch to it for now, but I would like to port bsh to jline 2 in a near future.
Comment 5 Michal Srb 2013-10-30 06:08:20 EDT
Fixed in bsh-1.3.0-28.fc21

Note You need to log in before you can comment on or make changes to this bug.