Bug 1023023 - [heads-up] Upcoming jline change in rawhide
[heads-up] Upcoming jline change in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhino (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1022897
  Show dependency treegraph
 
Reported: 2013-10-24 09:14 EDT by Severin Gehwolf
Modified: 2013-11-06 06:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 06:15:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-10-24 09:14:05 EDT
This bug is filed because rhino in rawhide lists jline as R/BR in its spec file. Please see bug 1022897 for more info. Note that jline will become version 2.x. It would be strongly preferred if rhino could be made to work with jline 2.x. If this is not possible please change the R/BR to jline1 (see bug 1022908). Note that jline1 might get retired in a future version of Fedora. As such jline 2.x should be used if at all possible.

Thanks for your cooperation!
Comment 1 Severin Gehwolf 2013-10-24 09:14:43 EDT
Please close this bug once rhino has been updated in rawhide.
Comment 2 Severin Gehwolf 2013-11-06 06:15:56 EST
Rhino has jline listed as Requires. I've tested the rhino shell with latest jline (which is version 2.x) from rawhide. It seems to be happy with it.

I've added "set +x" to the /usr/bin/rhino script and see this when launching rhino:

+ exec /usr/lib/jvm/java/bin/java -classpath /usr/share/java/rhino.jar:/usr/share/java/jline/jline.jar org.mozilla.javascript.tools.shell.Main

Output of $ rpm -qa | grep jline
jline-2.10-9.fc21.noarch

This makes me conclude that rhino works fine with latest jline. Noting to do here.

Note You need to log in before you can comment on or make changes to this bug.