Bug 1023159 - anaconda fails to install to a single partition
anaconda fails to install to a single partition
Status: CLOSED DUPLICATE of bug 960689
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 14:50 EDT by cornel panceac
Modified: 2014-01-29 13:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 11:51:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2013-10-24 14:50:20 EDT
Description of problem:
attempts to install fedora 20 alpha or beta tc5 on the first primary partition of the hard disk fail because anaconda is unable to find a suitable stage1 storage device.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1.boot netinstall medium
2.select custom partitioning
3.select the first partition as the root of the file system (ext4)
4.press "done"

Actual results:
anaconda provides a cryptic message and offers no way to go on unless you fix the mysterious error


Expected results:
anaconda installs the distribution on the primary partition


Additional info:
the first partition is 100gb in size, and is marked as bootable.
on the same system, fedora 17 x64 works just fine being installed on the other partitions (sda2,3,5,...)
Comment 1 cornel panceac 2013-11-04 10:45:52 EST
so the message in the main screen is: "Error checking storage configuration."
in ctrl-alt-f3, we get things like:

ERR anaconda:
- storage configuration failed: failed to find a suitable stage1 device
- you have not created a bootloader stage1 target device
- you have not created a bootable partition

And there"s no way i can get over this error. Same anaconda, was able just fine to install on 20 gb /dev/sda9 only, but on a system without UEFI.
Comment 2 David Shea 2013-11-04 10:59:10 EST
UEFI requires a EFI System Partition containing the bootloader and UEFI application. This cannot be the same partition as the root partition. For a UEFI system you need a minimum of two partitions: a / partition formatted using a Linux filesystem (xfs, ext4, etc.) and a EFI System Partition mounted at /boot/efi.
Comment 3 cornel panceac 2013-11-04 11:21:00 EST
Thank you David, this is good to know. However, it would have been nice to find this out from anaconda itself, instead of opening a ticket in bugzilla :)
Comment 4 cornel panceac 2013-11-06 11:11:19 EST
on one hand, it seems the /boot/efi is not required if you do not boot in uefi mode.

on the other hand, i"ve resized partitions to create some more space and then created the following partitions:

/dev/sda1 -> 4GB , for this i've tried /boot and /boot//efi, with ext4 or EFI system partition type

/dev/sda7 and /dev/sda8 with plenty of space (> 80 GB), ext4, for /home and /

in all cases, anaconda failed with same errors as reported above

for this test i've used Beta RC4 x64 netinst, fedora 20.
Comment 5 cornel panceac 2013-11-07 09:52:09 EST
another test i did: i've deleted the three target partitions, and clicked the link to have them automat6ically created for me. 

the error was: "doAutoPartition failed: failed to find a suitable stage1 device"
Comment 6 satellitgo 2013-11-07 10:00:49 EST
I have used a custom single partition setup: / ext4 bootable to install to USB (8Gb) for Sugar-desktop in the past. swap is bad for USB life
Comment 7 Adam Williamson 2014-01-27 20:06:49 EST
cornel, did you still have trouble with the final F20 on this system? are you sure you did things right? you must create a partition of type "EFI boot partition", on a GPT-labelled disk, and mount it at /boot/efi , to make things work.
Comment 8 cornel panceac 2014-01-28 08:26:42 EST
hi adam. last year, on November 7th, i've replied to bugzilla message. of course, replying to bugzilla is not good enough so the message never reached the intended recipient :)

So here it is, for real, this time:

"after _a lot_ of help from tflink, i"ve found that the first boot option was opticald drive in uefi mode. after getting rid of that and swithing to old style optical drive, anaconda is able to install to selected custom partitions. why this is not working for uefi mode, i can"t understand."
Comment 9 Adam Williamson 2014-01-28 11:49:58 EST
cornel: because you *have* to create an EFI system partition for a UEFI installation to boot successfully. You may find my recent blog post - https://www.happyassassin.net/2014/01/25/uefi-boot-how-does-that-actually-work-then/ - helpful in explaining why. The "EFI system partition" is just UEFI's way of replacing the dumb design, in the old BIOS/MBR world, of there being some "magic space" at the start of a disk (before the first partition) where the bootloader lives. In the UEFI/GPT world, bootloaders live on a real partition just like anything else on the disk: an EFI system partition.
Comment 10 Adam Williamson 2014-01-28 11:51:34 EST

*** This bug has been marked as a duplicate of bug 960689 ***
Comment 11 cornel panceac 2014-01-29 03:05:21 EST
Hi adam. although i do agree the anaconda error message should describe the real problem, the closing of this looks like an error to me since, as you can see from comment #5, there are more problems here, not just the error message. if, on the other hand, you know the oter problems were already fixed, we can live things as they are. thank you.
Comment 12 Adam Williamson 2014-01-29 13:18:56 EST
I suspect that's another known bug: https://bugzilla.redhat.com/show_bug.cgi?id=978430 .

Note You need to log in before you can comment on or make changes to this bug.