Bug 1023449 - [abrt] system-config-printer-libs-1.4.3-1.fc20: decorators.py:330:decorator:ValueError: Corrupt type signature
[abrt] system-config-printer-libs-1.4.3-1.fc20: decorators.py:330:decorator:V...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:ab39b51b3115885a3fd43d35bac...
:
: 1029689 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 08:59 EDT by Arik Kfir
Modified: 2013-11-13 03:59 EST (History)
3 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 02:39:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (878 bytes, text/plain)
2013-10-25 08:59 EDT, Arik Kfir
no flags Details
File: environ (923 bytes, text/plain)
2013-10-25 08:59 EDT, Arik Kfir
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1232947 None None None Never

  None (edit)
Description Arik Kfir 2013-10-25 08:59:27 EDT
Version-Release number of selected component:
system-config-printer-libs-1.4.3-1.fc20

Additional info:
reporter:       libreport-2.1.8
cmdline:        /usr/bin/python /usr/share/system-config-printer/scp-dbus-service.py
dso_list:       dbus-python-1.1.1-6.fc20.x86_64
executable:     /usr/share/system-config-printer/scp-dbus-service.py
kernel:         3.11.0-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
decorators.py:330:decorator:ValueError: Corrupt type signature

Traceback (most recent call last):
  File "/usr/share/system-config-printer/scp-dbus-service.py", line 297, in <module>
    class ConfigPrintingNewPrinterDialog(dbus.service.Object):
  File "/usr/share/system-config-printer/scp-dbus-service.py", line 370, in ConfigPrintingNewPrinterDialog
    signature='a{s}')
  File "/usr/lib/python2.7/site-packages/dbus/decorators.py", line 330, in decorator
    sig = tuple(Signature(signature))
ValueError: Corrupt type signature

Local variables in innermost frame:
member_name: 'DriverDownloadChecked'
emit_signal: <function emit_signal at 0x2073b18>
dbus_interface: 'org.fedoraproject.Config.Printing.NewPrinterDialog'
path_keyword: None
keyword: None
args: ['installed_files']
func: <function DriverDownloadChecked at 0x2073aa0>
signature: 'a{s}'
rel_path_keyword: None
Comment 1 Arik Kfir 2013-10-25 08:59:33 EDT
Created attachment 816131 [details]
File: backtrace
Comment 2 Arik Kfir 2013-10-25 08:59:37 EDT
Created attachment 816132 [details]
File: environ
Comment 3 Tim Waugh 2013-10-25 10:14:01 EDT
This just needs "a{s}" changing to "a(s)".
Comment 4 Fedora Update System 2013-10-25 12:06:27 EDT
system-config-printer-1.4.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-19710/system-config-printer-1.4.3-2.fc20
Comment 5 Fedora Update System 2013-10-25 12:07:02 EDT
system-config-printer-1.4.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-19726/system-config-printer-1.4.3-2.fc19
Comment 6 Fedora Update System 2013-10-25 20:58:29 EDT
Package system-config-printer-1.4.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19726/system-config-printer-1.4.3-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-06 02:39:31 EST
system-config-printer-1.4.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-10 02:44:27 EST
system-config-printer-1.4.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Jiri Popelka 2013-11-13 03:59:46 EST
*** Bug 1029689 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.