Bug 1029689 - [abrt] system-config-printer-libs-1.4.3-1.fc19: decorators.py:330:decorator:ValueError: Corrupt type signature
[abrt] system-config-printer-libs-1.4.3-1.fc19: decorators.py:330:decorator:V...
Status: CLOSED DUPLICATE of bug 1023449
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:ab39b51b3115885a3fd43d35bac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 17:43 EST by Dan Taylor
Modified: 2013-11-13 03:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 03:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (878 bytes, text/plain)
2013-11-12 17:43 EST, Dan Taylor
no flags Details
File: environ (639 bytes, text/plain)
2013-11-12 17:43 EST, Dan Taylor
no flags Details

  None (edit)
Description Dan Taylor 2013-11-12 17:43:47 EST
Version-Release number of selected component:
system-config-printer-libs-1.4.3-1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/share/system-config-printer/scp-dbus-service.py
dso_list:       dbus-python-1.1.1-5.fc19.x86_64
executable:     /usr/share/system-config-printer/scp-dbus-service.py
kernel:         3.11.6-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
decorators.py:330:decorator:ValueError: Corrupt type signature

Traceback (most recent call last):
  File "/usr/share/system-config-printer/scp-dbus-service.py", line 297, in <module>
    class ConfigPrintingNewPrinterDialog(dbus.service.Object):
  File "/usr/share/system-config-printer/scp-dbus-service.py", line 370, in ConfigPrintingNewPrinterDialog
    signature='a{s}')
  File "/usr/lib/python2.7/site-packages/dbus/decorators.py", line 330, in decorator
    sig = tuple(Signature(signature))
ValueError: Corrupt type signature

Local variables in innermost frame:
member_name: 'DriverDownloadChecked'
emit_signal: <function emit_signal at 0x1633b18>
dbus_interface: 'org.fedoraproject.Config.Printing.NewPrinterDialog'
path_keyword: None
keyword: None
args: ['installed_files']
func: <function DriverDownloadChecked at 0x1633aa0>
signature: 'a{s}'
rel_path_keyword: None

Potential duplicate: bug 1023449
Comment 1 Dan Taylor 2013-11-12 17:43:51 EST
Created attachment 823159 [details]
File: backtrace
Comment 2 Dan Taylor 2013-11-12 17:43:55 EST
Created attachment 823160 [details]
File: environ
Comment 3 Jiri Popelka 2013-11-13 03:59:46 EST
system-config-printer-1.4.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

*** This bug has been marked as a duplicate of bug 1023449 ***

Note You need to log in before you can comment on or make changes to this bug.