Bug 102355 - 0.6.70-1 isn't usable for zh_CN
0.6.70-1 isn't usable for zh_CN
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-printer (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-14 09:24 EDT by Akira TAGOH
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-18 23:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2003-08-14 09:24:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I couldn't set up the printer for zh_CN locale due to the warnings occurs like that:
(redhat-config-printer:18817): Gtk-WARNING **: Invalid input string

** (redhat-config-printer:18817): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

zh_CN/printconf.mo seems to be encoded by GB18030. but when I convert
po/zh_CN.po to UTF-8 and replace the charset to UTF-8, then use it instead, it
works. so I don't think the translation is broken. r-c-p might needs to call
i18n.textdomain_codeset() with UTF-8?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run r-c-p with zh_CN locale
2.
3.
    

Additional info:
Comment 1 Tim Waugh 2003-08-18 05:46:27 EDT
Please try redhat-config-printer 0.6.71-1.
Comment 2 Akira TAGOH 2003-08-18 23:34:58 EDT
confirmed the fix, thanks

Note You need to log in before you can comment on or make changes to this bug.