Bug 1023620 - broken ppp-2.4.5-eaptls-mppe-0.99.patch
broken ppp-2.4.5-eaptls-mppe-0.99.patch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
20
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1173012
  Show dependency treegraph
 
Reported: 2013-10-26 03:28 EDT by David Binderman
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version: ppp-2.4.5-35.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1173012 (view as bug list)
Environment:
Last Closed: 2015-01-07 18:55:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2013-10-26 03:28:32 EDT
I just compiled ppp-2.4.5 with extra gcc compiler flag -Wlogical-op

It said

> eap.c:236:2: warning: logical 'or' of collectively exhaustive tests is always 
true [-Wlogical-op]
> eap.c:1154:2: warning: logical 'or' of collectively exhaustive tests is always
 true [-Wlogical-op]
> eap.c:1189:2: warning: logical 'or' of collectively exhaustive tests is always
 true [-Wlogical-op]
> eap.c:2413:2: warning: logical 'or' of collectively exhaustive tests is always
 true [-Wlogical-op]
> eap.c:2457:2: warning: logical 'or' of collectively exhaustive tests is always
 true [-Wlogical-op]

It looks like the compiler is complaining about the eap_client_active macro.
It is defined in patch file ppp-2.4.5-eaptls-mppe-0.99.patch as follows

+#define    eap_client_active(esp)  ((esp)->es_client.ea_state != eapInitial ||\
+                (esp)->es_client.ea_state != eapPending ||\
+                (esp)->es_client.ea_state != eapClosed)

Suggest swap || for &&
Comment 1 Fedora Update System 2014-12-11 04:57:52 EST
ppp-2.4.5-35.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ppp-2.4.5-35.fc20
Comment 2 Fedora Update System 2014-12-11 04:59:51 EST
ppp-2.4.7-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/ppp-2.4.7-6.fc21
Comment 3 Fedora Update System 2014-12-13 04:37:57 EST
Package ppp-2.4.5-35.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ppp-2.4.5-35.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16810/ppp-2.4.5-35.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2015-01-07 18:55:15 EST
ppp-2.4.7-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-01-07 18:56:14 EST
ppp-2.4.5-35.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.