Bug 1023901 - Scalable ruby apps got 503 error when accessing and cannot be restart after migration
Scalable ruby apps got 503 error when accessing and cannot be restart after m...
Status: CLOSED DUPLICATE of bug 1021472
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 05:46 EDT by Meng Bo
Modified: 2015-05-14 19:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 16:05:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
restart_failed_for_ruby (38.92 KB, text/plain)
2013-10-28 05:46 EDT, Meng Bo
no flags Details

  None (edit)
Description Meng Bo 2013-10-28 05:46:48 EDT
Created attachment 816742 [details]
restart_failed_for_ruby

Description of problem:
Create scalable ruby apps on devenv-stage_528, upgrade server to latest devenv, and upgrade the gears. Check the scalable ruby apps after upgrade. The scalable ruby 1.8 and ruby 1.9 app return 503.

Version-Release number of selected component (if applicable):
devenv-stage_528 to devenv_3953

How reproducible:
always

Steps to Reproduce:
1. Create apps on devenv-stage ami
2. Upgrade server and migrate gears
3. Check the app status and access the app
4. Restart the app via rhc client

Actual results:
The app show as started state but the home page return 503 when accessing.

# rhc app restart ruby19s
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: 1df3c75ff691550d73691b73102595bf


Expected results:
The app should be accessible after migration.

Additional info:
Find the following info in the upgrade_result log:

            "start_gear": {
                "context": {
                    "warning": "Start gear failed with an exception: Failed to execute: 'control start' for /var/lib/openshift/526e24553c574c882000001a/ruby"
                }, 
                "errors": [], 
                "status": "complete"
            }, 
            "stop_gear": {
                "context": {
                    "warning": "Stop gear failed with an exception: undefined method `values' for nil:NilClass"
                }, 
                "errors": [], 
                "status": "complete"
            }, 


Development log when restarting app attached.
Comment 1 chunchen 2013-10-29 06:24:16 EDT
It is also reproduced on INT(devenv_3957).
Comment 2 Dan McPherson 2013-10-30 16:05:38 EDT

*** This bug has been marked as a duplicate of bug 1021472 ***

Note You need to log in before you can comment on or make changes to this bug.