Bug 1024199 - remote-viewer gui tool cannot recognize URI address with space character
remote-viewer gui tool cannot recognize URI address with space character
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Virtualization Bugs
:
Depends On:
Blocks: 1024204
  Show dependency treegraph
 
Reported: 2013-10-29 02:27 EDT by CongDong
Modified: 2014-10-14 02:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Type a URI with additional space characters Consequence: The URI is invalid, and the connection fails. Fix: Trim the URI string Result: Even with additional spaces, the connection will be attempted.
Story Points: ---
Clone Of:
: 1024204 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:30:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-10-29 02:27:54 EDT
Description of problem:
Use remote-viewer gui tool, if input the uri address with space character before or after the address, remote-viewer will fail to connect guest.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # remote-viewer
2. Input address with extra space character
"spice://10.66.7.84:5900 "
3. Click "Connect" button.

Actual results:
Error message :"Cannot determine the connection type form URI"

Expected results:
Remote-viewer should recognize the address and connect the guest successfully.

Additional info:
Comment 1 Marc-Andre Lureau 2013-11-04 07:17:02 EST
for future reference, better to put the commit:

commit 69ffdb50b9b83c031af4968ff40da084ecfda934
Author: Christophe Fergeau <cfergeau@redhat.com>
Date:   Tue Oct 29 10:14:29 2013 +0100

    Clean-up spaces before/after URI in connection dialog
Comment 3 Cui Lei 2014-06-05 01:49:42 EDT
I can reproduce this issue with:
virt-viewer-0.5.6-8.el6.x86_64

Verify the bug with virt-viewer-0.6.0-4.el6:
1. # remote-viewer
2. Input address with extra space character
"spice://ip_address:5900 "
3. Click "Connect" button.

The display window of virt-viewer displayed normally.

So change the status from 'ON_QA' to 'VERIFIED'.
Comment 4 errata-xmlrpc 2014-10-14 02:30:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.