Bug 1024204 - remote-viewer gui tool cannot recognize URI address with space character
remote-viewer gui tool cannot recognize URI address with space character
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Virtualization Bugs
:
Depends On: 1024199
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 02:40 EDT by CongDong
Modified: 2015-03-05 08:38 EST (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: Extra spaces in commandline arguments are not ignored Consequence: Extra spaces cause problems connecting to remote host Fix: trim spaces from URL before using it Result: extra spaces are ignored and application can connect properly
Story Points: ---
Clone Of: 1024199
Environment:
Last Closed: 2015-03-05 08:38:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-10-29 02:40:02 EDT
+++ This bug was initially created as a clone of Bug #1024199 +++
This bug can be reproduced on RHEL 7 with:
virt-viewer-0.5.7-2.el7.x86_64
So clone the bug.


Description of problem:
Use remote-viewer gui tool, if input the uri address with space character before or after the address, remote-viewer will fail to connect guest.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # remote-viewer
2. Input address with extra space character
"spice://10.66.7.84:5900 "
3. Click "Connect" button.

Actual results:
Error message :"Cannot determine the connection type form URI"

Expected results:
Remote-viewer should recognize the address and connect the guest successfully.

Additional info:
Comment 2 Marc-Andre Lureau 2013-11-04 07:17:34 EST
commit 69ffdb50b9b83c031af4968ff40da084ecfda934
Author: Christophe Fergeau <cfergeau@redhat.com>
Date:   Tue Oct 29 10:14:29 2013 +0100

    Clean-up spaces before/after URI in connection dialog
Comment 4 Jonathon Jongsma 2014-07-09 22:36:24 EDT
Fixed by rebase to 0.6.0
Comment 6 CongDong 2014-07-21 02:47:55 EDT
I can reproduce with : virt-viewer-0.5.7-7.el7.x86_64

VERIFY: virt-viewer-0.6.0-1.el7.x86_64
Steps:
1. # remote-viewer
2. Input address with extra space character
"spice://10.66.7.84:5900 " and "  spice://127.0.0.1:5900"
3. Click "Connect" button.

Result:
Can connect the guest, and the content in title bar is right.

As the result set VERIFIED.
Comment 8 errata-xmlrpc 2015-03-05 08:38:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.