Bug 1024286 - Update request: llvm 3.3 final (patch included)
Update request: llvm 3.3 final (patch included)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Včelák
Fedora Extras Quality Assurance
:
: 979809 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 06:28 EDT by Damian Wrobel
Modified: 2013-12-16 18:06 EST (History)
8 users (show)

See Also:
Fixed In Version: llvm-3.3-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:47:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
llvm-3.3-final.patch (6.83 KB, patch)
2013-10-29 06:30 EDT, Damian Wrobel
no flags Details | Diff

  None (edit)
Description Damian Wrobel 2013-10-29 06:28:03 EDT
llvm 3.3 has been released some time ago. Now we have rc3 which has the compiler-rt disabled which makes impossible to use the -faddress-sanitizer feature.

I've tested the 3.3 final on x86_64 and it seems to work fine. Please consider to update to that version.
Comment 1 Damian Wrobel 2013-10-29 06:30:39 EDT
Created attachment 817039 [details]
llvm-3.3-final.patch

Please find attached patch against git master.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6110724
Comment 2 Jan Včelák 2013-11-13 18:02:35 EST
*** Bug 979809 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-11-21 17:48:05 EST
llvm-3.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/llvm-3.3-2.fc20
Comment 4 Fedora Update System 2013-11-23 22:52:37 EST
Package llvm-3.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing llvm-3.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22023/llvm-3.3-2.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-26 09:25:55 EST
llvm-3.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/llvm-3.3-2.fc19
Comment 6 Fedora Update System 2013-11-30 03:45:27 EST
llvm-3.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/llvm-3.3-3.fc19
Comment 7 Fedora Update System 2013-12-13 22:47:42 EST
llvm-3.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-16 18:06:33 EST
llvm-3.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.