Bug 979809 - Fedora 19,18, and Rawhide have pre release versions of llvm 3.3 when it has had a stable release
Fedora 19,18, and Rawhide have pre release versions of llvm 3.3 when it has h...
Status: CLOSED DUPLICATE of bug 1024286
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 15:18 EDT by Khalil Choudhry
Modified: 2013-11-13 18:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 18:02:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Khalil Choudhry 2013-06-30 15:18:50 EDT
llvm and clang packages in fedora are using pre release versions of llvm 3.3:
https://apps.fedoraproject.org/packages/llvm

But a stable release has been made.
Release announcement (Mon, June 17) : http://lists.cs.uiuc.edu/pipermail/llvm-announce/2013-June/000046.html

This is just a request for an update to the package.
Comment 1 Jens Petersen 2013-08-20 23:30:59 EDT
No disagreement but note that the rc3 snapshot in Fedora is essentially
the final release modulo some release notes docs additions.

Diffstats:

 llvm-3.3.src/docs/CommandLine.rst                     |    2 
 llvm-3.3.src/docs/LangRef.rst                         |    9 
 llvm-3.3.src/docs/ReleaseNotes.rst                    |  224 +++++++++++++-----
 llvm-3.3.src/tools/clang/docs/ReleaseNotes.rst        |  103 ++------
 llvm-3.3.src/tools/clang/lib/Basic/Version.cpp        |    2 
 llvm.src/projects/compiler-rt                         |only
 llvm.src/projects/llvm-test                           |only
 llvm.src/utils/lit/lit/LitConfig.pyc                  |only
 llvm.src/utils/lit/lit/ProgressBar.pyc                |only
 llvm.src/utils/lit/lit/ShCommands.pyc                 |only
 llvm.src/utils/lit/lit/ShUtil.pyc                     |only
 llvm.src/utils/lit/lit/Test.pyc                       |only
 llvm.src/utils/lit/lit/TestFormats.pyc                |only
 llvm.src/utils/lit/lit/TestRunner.pyc                 |only
 llvm.src/utils/lit/lit/TestingConfig.pyc              |only
 llvm.src/utils/lit/lit/Util.pyc                       |only
 llvm.src/utils/lit/lit/__init__.pyc                   |only
 llvm.src/utils/lit/lit/discovery.pyc                  |only
 llvm.src/utils/lit/lit/main.pyc                       |only
 llvm.src/utils/llvm-build/llvmbuild/__init__.pyc      |only
 llvm.src/utils/llvm-build/llvmbuild/componentinfo.pyc |only
 llvm.src/utils/llvm-build/llvmbuild/configutil.pyc    |only
 llvm.src/utils/llvm-build/llvmbuild/main.pyc          |only
 llvm.src/utils/llvm-build/llvmbuild/util.pyc          |only
 24 files changed, 212 insertions(+), 128 deletions(-)
Comment 2 Jan Včelák 2013-11-13 18:02:35 EST

*** This bug has been marked as a duplicate of bug 1024286 ***

Note You need to log in before you can comment on or make changes to this bug.