Bug 1024304 - Redmine with ruby-1.9/ruby-1.8 and mysql-5.1 returns 503 after migration.
Redmine with ruby-1.9/ruby-1.8 and mysql-5.1 returns 503 after migration.
Status: CLOSED DUPLICATE of bug 1021472
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:16 EDT by Yujie Zhang
Modified: 2015-05-14 19:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 15:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full log file (98.29 KB, text/plain)
2013-10-29 07:16 EDT, Yujie Zhang
no flags Details
platform.log (1.67 MB, text/x-log)
2013-10-30 05:21 EDT, Wei Sun
no flags Details
ugrade.log (33.12 KB, text/x-log)
2013-10-30 05:22 EDT, Wei Sun
no flags Details

  None (edit)
Description Yujie Zhang 2013-10-29 07:16:32 EDT
Created attachment 817054 [details]
full log file

Description of problem:

Create rubyonrails and redmine application with ruby-1.9 and mysql-5.1 cartridges on old env, after migration, the rubyonrails and redmine application return 503 error, found the following result for rubyonrails applications:

"upgrade_script_ruby": {
                "status": "incomplete",
                "errors": [
                   
                ],

"start_gear": {
                "status": "complete",
                "errors": [
                   
                ],
                "context": {
                    "warning": "Start gear failed with an exception: Failed to execute: 'control start' for /var/lib/openshift/526f55f145ed468e39000036/ruby"
                }
            },
            "validate_gear": {
                "status": "complete",
                "errors": [
                   
                ],
                "context": {
                    "preupgrade_state": "started",
                    "postupgrade_response_code": "503",
                    "postupgrade_status": "Cart status for ruby [PROBLEM]: CLIENT_RESULT: Application is either stopped or inaccessible\n\nCart status for mysql [OK]: CLIENT_RESULT: MySQL is running\n\n"
                }
            }
        },

Version-Release number of selected component (if applicable):
devenv_3960

How reproducible:
always

Steps to Reproduce:
1.Create rubyonrails or redmine application on devenv-stage_528
2.Migrate to devenv_3960
3.Check the rubyonrails and redmine application

Actual results:

The rubyonrails and redmine application both return 503 error, full log please see in attachment.

Expected results:

The rubyonrails and redmine application should work correctly after migration.

Additional info:
Comment 1 Michal Fojtik 2013-10-29 08:38:24 EDT
Hi,

Could you also please provide the /var/log/openshift/node/platform.log? I guess the 'start' operation failure will be logged there.
Comment 2 Wei Sun 2013-10-30 05:21:44 EDT
Created attachment 817352 [details]
platform.log

Tried this bug on devenv_3966 which is upgraded from devenv-stage_528.

For rubyonrails quickstart,after migration,could access the app's url.

For redmine with ruby-1.9/ruby-1.8,after migration ,still could not access the app's url.
Comment 3 Wei Sun 2013-10-30 05:22:48 EDT
Created attachment 817353 [details]
ugrade.log
Comment 4 Dan McPherson 2013-10-30 15:24:20 EDT

*** This bug has been marked as a duplicate of bug 1021472 ***

Note You need to log in before you can comment on or make changes to this bug.