Bug 1024309 - The viewer window still open if remote-viewer gui tool cannot connect the guest
Summary: The viewer window still open if remote-viewer gui tool cannot connect the guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Christophe Fergeau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1024312
TreeView+ depends on / blocked
 
Reported: 2013-10-29 11:21 UTC by CongDong
Modified: 2014-10-14 06:30 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1024312 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:30:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1379 0 normal SHIPPED_LIVE virt-viewer bug fix update 2014-10-14 01:05:43 UTC

Description CongDong 2013-10-29 11:21:58 UTC
Description of problem:
If the remote-viewer gui tool fail to connect the guest, the viewer window still open.
After that, input a right uri to connect a guest, the window title will keep the wrong one you input first time.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # remote-viewer
2. Input a wrong address which does not exist, and try to connect
"spice://123456"
3. An error dialog comes out:
"Unable to connect to the graphic server spice://123456"
4. Click "OK" button, the gui tool will show again.
5. Input a right uri and connect the guest.

Actual results:
Step4, After click "OK", the remote-viewer gui tool will show again, but the remote-viewer window for the wrong address still opened.

Step5, can connect the guest successfully, but the window title is still the wrong one "spice://123456"

Expected results:
The window should be closed. 
But, if the window is reasonable, the window title should be corrected when connect another guest.

Additional info:

Comment 1 hyao@redhat.com 2013-11-20 09:31:56 UTC
I can reproduce the bug with package below: 
# rpm -qa virt-viewer
virt-viewer-0.5.6-8.el6.x86_64

Comment 2 Christophe Fergeau 2013-11-20 10:14:38 UTC
(In reply to CongDong from comment #0)
> If the remote-viewer gui tool fail to connect the guest, the viewer window
> still open.

Should be fixed by https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=2f890cf2f5faec0d859df3d8ce91a8f9ad7f5dfd

> After that, input a right uri to connect a guest, the window title will keep
> the wrong one you input first time.

And this one should be fixed by https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=b19a246c5cac54ff0570d482f78cc0172ea2d884

These issues are just cosmetic, moving them to 6.6.

Comment 3 Christophe Fergeau 2013-11-20 10:16:10 UTC
(In reply to Christophe Fergeau from comment #2)
> These issues are just cosmetic, moving them to 6.6.

Actually, the bug was already rhel-6.6.0? , I should not have changed the version field ;)

Comment 5 tingting zheng 2014-06-05 08:24:58 UTC
I can reproduce it with:
virt-viewer-0.5.6-10.el6.x86_64

Tested pass with:
virt-viewer-0.6.0-4.el6.x86_64

Steps:
1. # remote-viewer
2. Input a wrong address which does not exist, and try to connect
"spice://123456"
3. An error dialog comes out:
"Unable to connect to the graphic server spice://123456"
4. Click "OK" button, the remote-viewer GUI is still there but the remote-viewer window for the wrong address is closed.
5. Input a right uri and connect the guest,the console will be launched and the right window title is showed.

Refer to the above comments,move the bug to VERIFIED.

Comment 6 errata-xmlrpc 2014-10-14 06:30:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html


Note You need to log in before you can comment on or make changes to this bug.