Bug 1024312 - The viewer window still open if remote-viewer gui tool cannot connect the guest
The viewer window still open if remote-viewer gui tool cannot connect the guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Christophe Fergeau
Virtualization Bugs
:
Depends On: 1024309
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:24 EDT by CongDong
Modified: 2015-03-05 08:38 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: Connection failures not handled properly Consequence: After retrying and connecting properly, the window will show the old (failed) URL as the window title Fix: Close the display window upon connection failure, and reset the title on each retry Result: Windows always show the correct title.
Story Points: ---
Clone Of: 1024309
Environment:
Last Closed: 2015-03-05 08:38:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-10-29 07:24:12 EDT
+++ This bug was initially created as a clone of Bug #1024309 +++
This can be reproduced on RHEL7 with:
virt-viewer-0.5.7-2.el7.x86_64
So clone it to RHEL7.

Description of problem:
If the remote-viewer gui tool fail to connect the guest, the viewer window still open.
After that, input a right uri to connect a guest, the window title will keep the wrong one you input first time.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # remote-viewer
2. Input a wrong address which does not exist, and try to connect
"spice://123456"
3. An error dialog comes out:
"Unable to connect to the graphic server spice://123456"
4. Click "OK" button, the gui tool will show again.
5. Input a right uri and connect the guest.

Actual results:
Step4, After click "OK", the remote-viewer gui tool will show again, but the remote-viewer window for the wrong address still opened.

Step5, can connect the guest successfully, but the window title is still the wrong one "spice://123456"

Expected results:
The window should be closed. 
But, if the window is reasonable, the window title should be corrected when connect another guest.

Additional info:
Comment 2 hyao@redhat.com 2013-11-20 04:31:54 EST
I can reproduce the bug with package below: 
# rpm -qa virt-viewer
virt-viewer-0.5.7-2.el7.x86_64

remote-viewer gui tool fail to connect the guest, and the viewer window still open.
Open viewer by the correct url, the window title will keep the wrong one
Comment 3 Christophe Fergeau 2013-11-20 05:25:30 EST
(In reply to CongDong from comment #0)
> If the remote-viewer gui tool fail to connect the guest, the viewer window
> still open.

Should be fixed by https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=2f890cf2f5faec0d859df3d8ce91a8f9ad7f5dfd

> After that, input a right uri to connect a guest, the window title will keep
> the wrong one you input first time.

And this one should be fixed by https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=b19a246c5cac54ff0570d482f78cc0172ea2d884
Comment 5 Jonathon Jongsma 2014-07-09 22:36:43 EDT
Fixed by rebase to 0.6.0
Comment 7 CongDong 2014-07-21 02:05:29 EDT
I can reporduce with : virt-viewer-0.5.7-7.el7.x86_64

VERIFY:
Steps:
1. # remote-viewer
2. Input a wrong address which does not exist, and try to connect
"spice://123456"
3. An error dialog comes out:
"Unable to connect to the graphic server spice://123456"
4. Click "OK" button, the gui tool will show again.
5. Input a right uri and connect the guest.

Result:
Step4, error message is ok, and after the gui show again, no other window
Step5, can connect guest, the message in window title is right.

Also test with other uri like:
vnc://xxx.xxx.xxx.xxx:xxxx
spice://xxx.xxx.xxx.xxx:xxxx
$connection_file

All of them can get the expected result.

As the result, set VERIFIED.
Comment 9 errata-xmlrpc 2015-03-05 08:38:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.