Bug 102448 - can't print out the UTF-8 Chinese text
can't print out the UTF-8 Chinese text
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: bg5ps (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
Bill Huang
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-15 05:17 EDT by Akira TAGOH
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-22 02:52:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (4.35 KB, patch)
2003-08-18 05:36 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2003-08-15 05:17:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
bg5ps-1.3.0-utf8.patch seems to be not enough. bg5ps itself actually works. but
we use mpage as the page formatter bofore passing through bg5ps. so the problem
here is, npsMode doesn't work with UTF-8. it means we can't print out the UTF-8
text on zh_CN and zh_TW locale.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_TW.UTF-8 lpr chinese-utf8.txt
2.
3.
    

Additional info:
Comment 1 Akira TAGOH 2003-08-18 05:36:06 EDT
Created attachment 93704 [details]
proposed patch
Comment 2 Leon Ho 2003-08-20 21:16:36 EDT
Please check 1.3.0-15. However I got the following: 
 
GNU Ghostscript 7.07 (2003-05-17) 
Copyright (C) 2003 artofcode LLC, Benicia, CA.  All rights reserved. 
This software comes with NO WARRANTY: see the file PUBLIC for details. 
Loading NimbusRomNo9L-Regu font from 
/usr/share/fonts/default/Type1/n021003l.pfb... 2430764 1066949 1642520 
351150 0 done. 
Loading NimbusSanL-Regu font from 
/usr/share/fonts/default/Type1/n019003l.pfb... 2785628 1380013 1682712 
365686 0 done. 
Loading NimbusMonL-Regu font from 
/usr/share/fonts/default/Type1/n022003l.pfb... 3090216 1614401 1702808 
371973 0 done. 
Can't find (or can't open) font file 
/usr/share/ghostscript/Resource/Font/OurCharSet-Bold. 
Can't find (or can't open) font file OurCharSet-Bold. 
Substituting font Helvetica-Bold for OurCharSet-Bold. 
Loading NimbusSanL-Bold font from 
/usr/share/fonts/default/Type1/n019004l.pfb... 3187264 1707091 1722904 
384390 0 done. 
Loading NimbusRomNo9L-Medi font from 
/usr/share/fonts/default/Type1/n021004l.pfb... 3324504 1785217 1722904 
363869 0 done. 
Error: /undefinedresource in --findresource-- 
Operand stack: 
   unijis   Ryumin-Light-UniJIS-UTF8-H   Font   Ryumin-Light-UniJIS-UTF8-H   
(Ryumin-Light-UniJIS-UTF8-H)   12   Ryumin-Light   UniJIS-UTF8-H   
UniJIS-UTF8-H   --dict:0/10(G)--   Ryumin-Light   false   Ryumin-Light   
Ryumin-Light   CIDFont   --nostringval--   CMap   CIDFont   CMap   CIDFont 
Execution stack: 
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   
%stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   
%stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   1   3   
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--   2   3   
%oparray_pop   3   3   %oparray_pop   --nostringval--   --nostringval--   16   4   
%oparray_pop   --nostringval--   19   5   %oparray_pop   --nostringval--   
--nostringval--   --nostringval--   --nostringval-- 
Dictionary stack: 
   --dict:1060/1123(ro)(G)--   --dict:0/20(G)--   --dict:100/200(L)--   
--dict:17/17(ro)(G)--   --dict:0/10(L)--   --dict:16/24(ro)(G)-- 
Current allocation mode is local 
Last OS error: 2 
Current file position is 4269 
GNU Ghostscript 7.07: Unrecoverable error, exit code 1 
 
Comment 3 Akira TAGOH 2003-08-21 02:31:44 EDT
It looks like the gs bug. please install the latest ghostscript and try this again.
Comment 4 Leon Ho 2003-08-21 22:08:53 EDT
Thanks. it is working now. However I assume it is still a bit slower because it still 
search for OurCharSet-Bold font. 
 
GNU Ghostscript 7.07 (2003-05-17) 
Copyright (C) 2003 artofcode LLC, Benicia, CA.  All rights reserved. 
This software comes with NO WARRANTY: see the file PUBLIC for details. 
Loading NimbusRomNo9L-Regu font from 
/usr/share/fonts/default/Type1/n021003l.pfb... 2430764 1068457 1642520 
351150 0 done. 
Loading NimbusSanL-Regu font from 
/usr/share/fonts/default/Type1/n019003l.pfb... 2785628 1381521 1682712 
365686 0 done. 
Loading NimbusMonL-Regu font from 
/usr/share/fonts/default/Type1/n022003l.pfb... 3090216 1615929 1702808 
371973 0 done. 
Can't find (or can't open) font file 
/usr/share/ghostscript/Resource/Font/OurCharSet-Bold. 
Can't find (or can't open) font file OurCharSet-Bold. 
Substituting font Helvetica-Bold for OurCharSet-Bold. 
Loading NimbusSanL-Bold font from 
/usr/share/fonts/default/Type1/n019004l.pfb... 3187264 1708619 1722904 
384390 0 done. 
Loading NimbusRomNo9L-Medi font from 
/usr/share/fonts/default/Type1/n021004l.pfb... 3324504 1786761 1722904 
363869 0 done. 
>>showpage, press <return> to continue<< 
 
Comment 5 Akira TAGOH 2003-08-22 02:46:58 EDT
No, finding non-existing fonts isn't a reason of slow. correctly mpage is using
UTF-8 CMap to handle the UTF-8 characters, and UTF-8 CMap is bigger than other
CMap. If it's called as bug, actually ghostscript should has the performance
issue. that's all. I don't think this patch affects any performance issue.
Comment 6 Leon Ho 2003-08-22 02:52:37 EDT
Great thanks. 

Note You need to log in before you can comment on or make changes to this bug.