Bug 1024556 - [ALL_LANG] Red Hat Access Plug-in is unlocalized
[ALL_LANG] Red Hat Access Plug-in is unlocalized
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: redhat-access-plugin-openstack (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: z3
: 6.0 (Juno)
Assigned To: Dan Varga
Ido Ovadia
: i18n, Reopened, ZStream
: 1024595 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 19:38 EDT by Yuko Katabami
Modified: 2017-07-24 13:03 EDT (History)
12 users (show)

See Also:
Fixed In Version: redhat-access-plugin-openstack-7.0.0-0.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 16:13:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Red Hat Access Plug-in is unlocalized (76.12 KB, image/png)
2013-10-29 19:38 EDT, Yuko Katabami
no flags Details

  None (edit)
Description Yuko Katabami 2013-10-29 19:38:59 EDT
Created attachment 817200 [details]
Red Hat Access Plug-in is unlocalized

Description of problem:
Red Hat Access Plug-in within Horizon Web Interface is not localized.

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Horizon
2. Change the language setting under "User Settings" to a language other than English then save the setting. 
3. Make sure that UI is displayed in the selected language.
4. Click on "Red Hat" button on the left side panel.

Actual results:
Search page is displayed but all the strings are unlocalized.

Expected results:
It should be localized.

Additional info:
Screenshot attached.
Comment 1 Yuko Katabami 2013-10-29 19:54:12 EDT
Hi Keith and Dan,

I am RHOS/RHEV localization lead / translator, currently conducting L10N QA event on RHOS 4.0 Horizon.
Julie Pichon suggested to contact you for this matter and I have added your email addresses to this BZ.

The bug is as described as above.
I am aware that this is a new plug-in and has never been localized, but it is desirable to be localized.

FYI, I have also filed a bug against RHEVM when I conducted l10n QA event for RHEV 3.3: https://bugzilla.redhat.com/show_bug.cgi?id=1009722
As it seems to be the same plug-in, localization would better be done in a single place then it can be shared across different RH products.

Please let me know if you require any further information.

Kind regards,

Yuko
Comment 3 Dan Varga 2013-12-04 10:43:59 EST
*** Bug 1024595 has been marked as a duplicate of this bug. ***
Comment 4 Dan Varga 2013-12-04 10:58:06 EST
Waiting on additional support from the customer portal to make this seamless.  Currently, searched documents and log file diagnosis would be return english solutions.
Comment 18 Ido Ovadia 2015-04-19 10:50:28 EDT
Verified
========

redhat-access-plugin-openstack-6.0.3-1.el7ost.noarch
Comment 20 errata-xmlrpc 2015-05-05 09:31:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0928.html
Comment 22 Yuko Katabami 2015-05-22 09:14:17 EDT
Since I have not been able to get any response, I am re-opening this.
We really need this to be properly resolved.
Hope someone can look into it.
Comment 23 Dan Varga 2015-05-22 09:23:46 EDT
Yuko,

This should be fixed via https://bugzilla.redhat.com/show_bug.cgi?id=1220311.
Comment 25 Ido Ovadia 2015-08-16 11:07:55 EDT
Failed QA
=========
redhat-access-plugin-openstack-6.0.3-1.el7ost.noarch
Comment 27 Yuko Katabami 2015-10-28 18:02:32 EDT
Hi Scott,Dan, Keith,

Most of issues we reported earlier this year are still unresolved.
(see the list provided in my previous message)
Is this targeting OSP-8 now?

Note You need to log in before you can comment on or make changes to this bug.