Bug 1024573 - dependency error with redhat-support-plugin-rhev-3.2.1-2
dependency error with redhat-support-plugin-rhev-3.2.1-2
Status: CLOSED DUPLICATE of bug 1017245
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Spenser Shumaker
gss
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 21:02 EDT by Bryan Yount
Modified: 2013-10-30 10:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 10:08:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 526403 None None None Never

  None (edit)
Description Bryan Yount 2013-10-29 21:02:25 EDT
Description of problem:
If a customer runs a normal "yum update" on the RHEL system running RHEV-M 3.2.2 or 3.2.3, with redhat-support-plugin-rhev-3.2.0-11 installed, they will receive a dependency error due to the latest version of the support plugin available on RHN.

Version-Release number of selected component (if applicable):
rhevm-3.2.3-0.42
redhat-support-plugin-rhev-3.2.0-11

How reproducible:
Very

Steps to Reproduce:
1. Install RHEV 3.2.2 or 3.2.3 with redhat-support-plugin-rhev < 3.2.1-2
2. yum update

Actual results:

-----------terminal snippet-----------
Error: Package: redhat-support-plugin-rhev-3.2.1-2.el6ev.noarch (rhel-x86_64-server-6-rhevm-3.2)
           Requires: rhevm >= 3.2.4
           Installed: rhevm-3.2.3-0.42.el6ev.noarch (@rhel-x86_64-server-6-rhevm-3.2)
               rhevm = 3.2.3-0.42.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
-----------terminal snippet-----------

Expected results:
The "yum update" should complete successfully.

Additional info:
Most likely the support plugin should be added to the yum-versionlock list or the dependency requirements are too strict. Customers may want to run "yum update" on their systems without being forced to run a rhevm-upgrade.
Comment 2 Spenser Shumaker 2013-10-30 09:44:12 EDT
This is a duplicate of bz101724.  We have agreed the best solution is to create a document stating the user must run rhevm-upgrade to upgrade both rhevm and the plugin.  After running rhevm-upgrade, yum update will behave normally.  This bug exists because rhevm is version locked while the plugin is not and version 3.2.1 of the plugin requires a specific version of rhevm. Lee Yarwood has agreed to create the documentation.
Comment 3 Spenser Shumaker 2013-10-30 10:08:54 EDT
The fix is addressed in the errata here[1].  Closing this bug as fixed.

[1] - https://errata.devel.redhat.com/errata/details/15877

*** This bug has been marked as a duplicate of bug 1017245 ***

Note You need to log in before you can comment on or make changes to this bug.