Bug 1024616 - It shows RHEV-H 6.4 in the boot interface while the OS is RHEV-H 6.5 actually
It shows RHEV-H 6.4 in the boot interface while the OS is RHEV-H 6.5 actually
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.4
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 1027428 rhevh-for-rhev-3.3
  Show dependency treegraph
 
Reported: 2013-10-30 01:41 EDT by Longjun Song
Modified: 2013-12-19 09:42 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:42:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a snapshot of the bug (14.05 KB, image/png)
2013-10-30 01:41 EDT, Longjun Song
no flags Details

  None (edit)
Description Longjun Song 2013-10-30 01:41:02 EDT
Created attachment 817274 [details]
a snapshot of the bug

Description of problem:
After installing the rhev-hypervisor6-6.5-20131029.0.3.2.el6 and booting to
the OS, it will show "Red Hat Enterprise Virtualization Hypervisor 6.4" but
the OS is 6.5 actually.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20131029.0.3.2.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.5-20131029.0.3.2.el6 from any media.
2. When booting to the OS, it will show "Red Hat Enterprise Virtualization Hypervisor 6.4"


Actual results:

Expected results:
It should show "Red Hat Enterprise Virtualization Hypervisor 6.5" to client

Additional info:
Comment 2 Guohua Ouyang 2013-10-30 03:33:36 EDT
is it the initrd0.img not updated?

tested an iso modified by edit-node, which initr0.img is rebuilt, its plymouth display 6.5
Comment 3 Guohua Ouyang 2013-10-30 03:51:10 EDT
(In reply to Ouyang guohua from comment #2)
> is it the initrd0.img not updated?
> 
> tested an iso modified by edit-node, which initr0.img is rebuilt, its
> plymouth display 6.5

Checked the etc/system-release file after gunzip the initrd0.img, it's "Red Hat Enterprise Virtualization Hypervisor release 6.4".
Comment 4 Mike Burns 2013-10-30 10:25:12 EDT
The issue stems from some bad assumptions made a long time ago that we would have a single ovirt-node version for each minor rhel release.  There are ways to fix this, but it's not an easy fix.  

The *simple* fix is to simply update the ovirt-node spec file to set 6.5

The complex fix is to set this value dynamically during the build.
Comment 10 Longjun Song 2013-11-07 02:48:30 EST
This bug has been fixed at package rhevh-6.5-20131106.0.3.2.el6
Comment 11 Longjun Song 2013-11-07 02:53:04 EST
Switch the status to POST and ignore the last comment because I should verify this bug at 6.4.z

Note You need to log in before you can comment on or make changes to this bug.