Bug 1027428 - It shows RHEV-H 6.4 in the boot interface while the OS is RHEV-H 6.5 actually
It shows RHEV-H 6.4 in the boot interface while the OS is RHEV-H 6.5 actually
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: ZStream
: 1027566 1029294 (view as bug list)
Depends On: 1024616
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 14:32 EST by Idith Tal-Kohen
Modified: 2013-11-27 19:12 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-17.el6_4.13
Doc Type: Bug Fix
Doc Text:
The hypervisor boot interface showed an incorrect operating system version because the /etc/system-release file was not updated dynamically. Now, the /etc/system-release file is updated within the chroot when initrd is rebuilt, so the operating system version displays correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 11:48:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Idith Tal-Kohen 2013-11-06 14:32:22 EST
This bug has been copied from bug #1024616 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 Longjun Song 2013-11-07 02:54:14 EST
This bug has been fixed at package rhevh-6.5-20131106.0.3.2.el6
Comment 8 Fabian Deutsch 2013-11-07 05:42:12 EST
*** Bug 1027566 has been marked as a duplicate of this bug. ***
Comment 9 cshao 2013-11-08 02:08:17 EST
Test version:
rhev-hypervisor6-6.5-20131107.0.3.2
ovirt-node-2.5.0-17.el6_4.14

Test steps:
1. Clean install rhev-hypervisor6-6.5-20131107.0.3.2 and enter into login screen, 2. check rhev-h version

Test result:
RHEV-H can show correct version info.

So the bug is fixed.
Comment 10 cshao 2013-11-08 02:48:52 EST
Hi Fabiand,

This bug need to change status to 'ON_QA', after that, we will change it to verified. 

Thanks!
Comment 11 Lei Wang 2013-11-11 10:49:58 EST
Based on comment 9 and 10, move this bug to verified.
Comment 12 Fabian Deutsch 2013-11-14 08:42:23 EST
*** Bug 1029294 has been marked as a duplicate of this bug. ***
Comment 13 Lei Wang 2013-11-17 10:12:19 EST
@cshao, please help validate that bug 1029294 also has been fixed, thanks!
Comment 14 Lei Wang 2013-11-17 10:15:05 EST
(In reply to Lei Wang from comment #13)
> @cshao, please help validate that bug 1029294 also has been fixed, thanks!

and another bug 1027566 duplicated to this bug.
Comment 15 cshao 2013-11-18 00:21:34 EST
(In reply to Lei Wang from comment #13)
> @cshao, please help validate that bug 1029294 also has been fixed, thanks!

Test version:
rhev-hypervisor6-6.5-20131115.0.3.2.el6_5
ovirt-node-2.5.0-17.el6_4.14.noarch

Test steps:
1. Install rhev-hypervisor6-6.5-20131115.0.3.2.el6_5 from pxe.
2. Focus on plymouth, 
3. Enter Login page, check version info.
4. Check if all packages are signed.

Test result:
1. RHEV-H show the correct version info in plymouth and and login page.
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20131115.0.3.2.el6_5)

2. All packages are signed.

So the bug is fixed, change bug status to VERIFIED.
Comment 17 errata-xmlrpc 2013-11-20 11:48:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1528.html

Note You need to log in before you can comment on or make changes to this bug.