This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 1024701 - [rfe] debuginfo-install plugin: add passive feature to keep debuginfo packages in sync
[rfe] debuginfo-install plugin: add passive feature to keep debuginfo package...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
All Linux
low Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
:
: 1070109 1070478 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 05:39 EDT by Petr Spacek
Modified: 2016-03-13 19:56 EDT (History)
23 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.17-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-13 19:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora.repo (1.49 KB, text/plain)
2013-10-30 05:39 EDT, Petr Spacek
no flags Details

  None (edit)
Description Petr Spacek 2013-10-30 05:39:21 EDT
Created attachment 817371 [details]
fedora.repo

Description of problem:
Disclamer: I realize that this can be 'feature', but it definitelly is a yum vs. dnf difference in behavior.

'yum upgrade' upgrades debuginfo packages even if debuginfo repos are not enabled, DNF ignores debuginfo packages from disabled repos.

Version-Release number of selected component (if applicable):
dnf-0.3.11-3.git7bdc9e1.fc19.noarch

How reproducible:
100 %

Steps to Reproduce:
1. install some debuginfo package, e.g. krb5-debuginfo: $ yum install krb5-debuginfo
2. downgrade the package to an older version: $ yum downgrade krb5-debuginfo
3. try to do full upgrade: $ yum upgrade
4. compare the result with $ dnf upgrade

Actual results:
DNF doesn't upgrade debuginfo packages.

$ sudo yum upgrade
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit, versionlock
Resolving Dependencies
--> Running transaction check
---> Package krb5-debuginfo.x86_64 0:1.11.3-1.fc19 will be updated
---> Package krb5-debuginfo.x86_64 0:1.11.3-10.fc19 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================================
 Package                                   Arch                              Version                                    Repository                                    Size
===========================================================================================================================================================================
Updating:
 krb5-debuginfo                            x86_64                            1.11.3-10.fc19                             updates-debuginfo                            4.0 M

Transaction Summary
===========================================================================================================================================================================
Upgrade  1 Package

Total size: 4.0 M
Is this ok [y/d/N]: N
Exiting on user command
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-10-30.10-27.khxHIO.yumtx

$ sudo dnf upgrade
Setting up Upgrade Process
Resolving Dependencies
--> Starting dependency resolution
--> Finished dependency resolution
Nothing to do


Expected results:
DNF behaves in the same way as YUM... Sorry! :-)

Additional info:
Debuginfo repo is disabled in fedora.repo file, but yum (I guess) enables it for upgrades if any *debuginfo package is installed. I'm attaching my fedora.repo file.
Comment 1 Ales Kozumplik 2013-10-30 09:04:36 EDT
This is done through the auto-updates-debuginfo package. Even the comment 0 sounds like you are a bit confused where this functionality is coming from and it doesn't look like a consistent and clear feature to me. 

Leaving this at low prio with a negative outlook.
Comment 2 Ales Kozumplik 2014-02-26 04:31:05 EST
*** Bug 1070109 has been marked as a duplicate of this bug. ***
Comment 3 Ben Boeckel 2014-02-27 03:21:53 EST
*** Bug 1070478 has been marked as a duplicate of this bug. ***
Comment 4 Ankur Sinha (FranciscoD) 2014-09-03 00:52:59 EDT
I was going to file a new bug but ran into this RFE.

Would it be possible to please provide a command to update the installed debuginfo packages on a system? I think yum has an update-debuginfo plugin that is activated when debuginfo packages are installed. Something similar for dnf would be nice. If not a plugin that updates the packages automatically, can an "update" command be added to the debuginfo-install plugin or an extension to make a debuginfo-update command that will provide similar functionality?

Version-Release number of selected component (if applicable):

dnf-plugins-core-0.1.2-99.1134.20140828gitcad4521.fc21.noarch

Thanks,
Ankur
Comment 5 Andy Grover 2015-05-12 16:15:13 EDT
I thought dnf wasn't supposed to have any feature regressions against yum. Is this not the case? I just upgraded to F22 beta and I'm having to update my debuginfo packages by hand.
Comment 6 Jan Zeleny 2015-05-13 02:55:52 EDT
If that was the case, we would never implement dnf in the first place, as there would be no reason to. Our goal is to have as few use case (not feature) differences as possible. The way how we work towards that goal is to carefully evaluate each request, put it in the context of the entire distribution, other requests that we have and prioritize accordingly.

That being said, what you seem to be requesting here is a plugin that would enable repos that are marked as origin of installed packages, does that sound right? I'm not sure it makes much sense to limit this functionality just to debuginfo packages.

Anyway, I'm moving this to dnf-plugins-extras, as it breaks the semantics of enabled/disabled repos and it therefore should not be a core functionality of dnf.
Comment 7 Marek Zdunek 2015-06-26 07:53:02 EDT
Where is auto-update-debuginfo for dnf? I miss that so much after upgrade to fc22.
Comment 8 Michael Mráka 2015-07-13 07:38:10 EDT
If you want to get updates for debuginfo packages just enable *-debuginfo repositories.
Comment 9 Fabrice Bellet 2015-07-13 14:20:33 EDT
The problem with enabling *-debuginfo repos is that we may install packages from updates-testing-debuginfo when updates-testing repo is not enabled. Enabled debuginfo repos should be limited to the set of non-debuginfo repos already enabled.
Comment 10 Christian Stadelmann 2015-11-14 07:25:46 EST
How about doing this:
1. add a new plugin to dnf-plugins-core named "debuginfo-upgrade" (similiar to "debuginfo-install")
2. It does a `dnf upgrade`, with all -debuginfo repositories enabled for enabled repositories.

Right now I am doing this as an alias:
alias upgrade-debuginfo='dnf --enablerepo=fedora-debuginfo --enablerepo=updates-debuginfo --enablerepo=updates-testing-debuginfo'
which works fine but is not flexible because it doesn't respect which repos are enabled. If updates-testing is disabled, incorrect debuginfo packages will be installed.
Comment 11 Michael Mráka 2016-01-05 07:06:30 EST
Implemented in PR
https://github.com/rpm-software-management/dnf-plugins-core/pull/140
Comment 12 Honza Silhan 2016-02-01 08:16:38 EST
*** Bug 1302886 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2016-02-25 08:53:51 EST
dnf-plugins-core-0.1.17-1.fc23 dnf-1.1.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 14 Fedora Update System 2016-02-25 08:55:48 EST
dnf-plugins-core-0.1.17-1.fc22 dnf-1.1.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 15 Fedora Update System 2016-03-09 12:20:01 EST
dnf-1.1.7-2.fc23 dnf-plugins-core-0.1.17-1.fc23 libsolv-0.6.19-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 16 Fedora Update System 2016-03-09 12:21:02 EST
dnf-1.1.7-2.fc22 dnf-plugins-core-0.1.17-1.fc22 libsolv-0.6.19-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 17 Fedora Update System 2016-03-10 11:52:23 EST
dnf-1.1.7-2.fc22, dnf-plugins-core-0.1.17-1.fc22, libsolv-0.6.19-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f673381075
Comment 18 Fedora Update System 2016-03-10 11:54:45 EST
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0123ce82c1
Comment 19 Fedora Update System 2016-03-13 19:55:10 EDT
dnf-1.1.7-2.fc23, dnf-plugins-core-0.1.17-1.fc23, libsolv-0.6.19-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.