Bug 1301265 - dnf debuginfo-install does not work
dnf debuginfo-install does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
: 1302886 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-23 05:02 EST by George R. Goffe
Modified: 2016-07-21 10:32 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 10:32:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
flat file showing gdb sessions and dnf debug-install session (15.34 KB, text/plain)
2016-01-23 05:02 EST, George R. Goffe
no flags Details

  None (edit)
Description George R. Goffe 2016-01-23 05:02:03 EST
Created attachment 1117430 [details]
flat file showing gdb sessions and dnf debug-install session

Description of problem:

I'm attempting to create a coredump trace and got a msg from gdb that more debug-info files were required. I installed them with the command gdb gave me but they're already installed.

Version-Release number of selected component (if applicable):
gdb-7.10.50.20160106-44.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1.see enclosed log file
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Kratochvil 2016-01-23 06:46:38 EST
Those will be some repos out of sync or so, what is the output of these?
rpm -q bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
rpm -V bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
rpm -q bzip2-libs libgcc libstdc++
rpm -V bzip2-libs libgcc libstdc++
Comment 2 George R. Goffe 2016-01-23 12:19:16 EST
Jan,

Here you go.

Thanks for your help!

George...


fc24-rawhide-bash 4.3 ~# sh -xv showme
module () {  eval `/usr/bin/modulecmd bash $*`
}
scl () {  local CMD=$1;
 if [ "$CMD" = "load" -o "$CMD" = "unload" ]; then
 eval "module $@";
 else
 /usr/bin/scl "$@";
 fi
}
rpm -q bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
+ rpm -q bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
package bzip2-debuginfo-1.0.6-19.fc24.x86_64 is not installed
package gcc-debuginfo-5.3.1-3.fc24.x86_64 is not installed
rpm -V bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
+ rpm -V bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
package bzip2-debuginfo-1.0.6-19.fc24.x86_64 is not installed
package gcc-debuginfo-5.3.1-3.fc24.x86_64 is not installed
rpm -q bzip2-libs libgcc libstdc++
+ rpm -q bzip2-libs libgcc libstdc++
bzip2-libs-1.0.6-19.fc24.x86_64
bzip2-libs-1.0.6-19.fc24.i686
libgcc-5.3.1-3.fc24.x86_64
libgcc-5.3.1-3.fc24.i686
libstdc++-5.3.1-3.fc24.x86_64
libstdc++-5.3.1-3.fc24.i686
rpm -V bzip2-libs libgcc libstdc++
+ rpm -V bzip2-libs libgcc libstdc++
fc24-rawhide-bash 4.3 ~# exit

Script done on Sat 23 Jan 2016 10:17:06 AM MST
Comment 3 Jan Kratochvil 2016-01-23 12:38:46 EST
I have reproduced here it really does not work with fresh Rawhide mock shell.
But that is a dnf bug.

dnf debuginfo-install installs glibc-debuginfo and nss-softokn-debuginfo (I do not know why these two).  But the two needed packages are not installed: bzip2-debuginfo and gcc-debuginfo


# rpm -q bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64 bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64
package bzip2-debuginfo-1.0.6-19.fc24.x86_64 is not installed
package gcc-debuginfo-5.3.1-3.fc24.x86_64 is not installed
bzip2-libs-1.0.6-19.fc24.x86_64
libgcc-5.3.1-3.fc24.x86_64
libstdc++-5.3.1-3.fc24.x86_64
# rpm -V bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64
# dnf list bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
Last metadata expiration check performed 0:00:42 ago on Sat Jan 23 18:31:19 2016.
Error: No matching Packages to list
# dnf list --enablerepo='*debug*' bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
Last metadata expiration check performed 0:00:56 ago on Sat Jan 23 18:31:19 2016.
Available Packages
bzip2-debuginfo.x86_64                                                1.0.6-19.fc24                                                 debug
gcc-debuginfo.x86_64                                                  5.3.1-3.fc24                                                  debug
# dnf debuginfo-install bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64
No such command: debuginfo-install. Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(debuginfo-install)'"
# dnf install 'dnf-command(debuginfo-install)'
Last metadata expiration check performed 0:00:00 ago on Sat Jan 23 18:33:14 2016.
Dependencies resolved.
[...]
Installed:
  dnf-plugins-core.noarch 0.1.15-1.fc24                           python3-dnf-plugins-core.noarch 0.1.15-1.fc24                          
Complete!
# dnf debuginfo-install bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64
Last metadata expiration check performed 0:00:00 ago on Sat Jan 23 18:33:20 2016.
Dependencies resolved.
Nothing to do.
Complete!
# dnf debuginfo-install --enablerepo='*debug*' bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64
[...]
Installed:
  glibc-debuginfo.x86_64 2.22.90-29.fc24   glibc-debuginfo-common.x86_64 2.22.90-29.fc24   nss-softokn-debuginfo.x86_64 3.21.0-5.fc24
Complete!
# rpm -q bzip2-debuginfo-1.0.6-19.fc24.x86_64 gcc-debuginfo-5.3.1-3.fc24.x86_64
package bzip2-debuginfo-1.0.6-19.fc24.x86_64 is not installed
package gcc-debuginfo-5.3.1-3.fc24.x86_64 is not installed
# rpm -q dnf dnf-plugins-core
dnf-1.1.5-1.fc24.noarch
dnf-plugins-core-0.1.15-1.fc24.noarch
# _
Comment 4 Jan Kratochvil 2016-01-23 12:40:05 EST
The requirement to add --enablerepo='*debug*' to debuginfo-install also looks suspicious.
Comment 5 Michael Mráka 2016-01-25 05:22:17 EST
Seems to be fixed (as a side effect) in bug #1024701

https://github.com/rpm-software-management/dnf-plugins-core/pull/140
Comment 6 Michael Mráka 2016-02-02 03:25:31 EST
*** Bug 1302886 has been marked as a duplicate of this bug. ***
Comment 7 Jan Kratochvil 2016-02-02 16:41:05 EST
*** Bug 1302886 has been marked as a duplicate of this bug. ***
Comment 8 Jan Kurik 2016-02-24 10:33:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 9 George R. Goffe 2016-03-28 18:15:52 EDT
Jan et. al.,

Are you sure it doesn't exist in Fedora 22 or 23?

Regards,

George...
Comment 10 Mike McCune 2016-03-28 19:16:15 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 11 Jan Kratochvil 2016-03-30 16:46:11 EDT
(In reply to George R. Goffe from comment #9)
> Are you sure it doesn't exist in Fedora 22 or 23?

It probably does exist there but debuginfo-install is just a convenience feature.  You can always do the same with some:
  dnf --enablerepo='*debug*' install ...
Whether DNF team backports it to F-22/F-23 I do not find too important myself.
Comment 12 George R. Goffe 2016-03-30 17:56:35 EDT
Jan,

Thank you for your responses and hard work.

Regards,

George...
Comment 13 Fedora Admin XMLRPC Client 2016-07-08 05:26:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.