Bug 1024849 - SELinux is preventing /usr/libexec/postfix/local from write, open access on the file /root/Maildir/tmp/1383138667.P18310.cyclops.zoidtechnologies.com.
SELinux is preventing /usr/libexec/postfix/local from write, open access on t...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:779ef638cf95ba348413bd9bcc7...
:
: 1024791 1024974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 10:02 EDT by Jeff MacDonald
Modified: 2013-11-04 11:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 11:56:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff MacDonald 2013-10-30 10:02:21 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/local from write, open access on the file /root/Maildir/tmp/1383138667.P18310.cyclops.zoidtechnologies.com.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/root/Maildir/tmp/1383138667.P18310.cyclops.zoidtechnologies.com default label should be mail_home_rw_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /root/Maildir/tmp/1383138667.P18310.cyclops.zoidtechnologies.com

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that local should be allowed write open access on the 1383138667.P18310.cyclops.zoidtechnologies.com file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep local /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_local_t:s0
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/Maildir/tmp/1383138667.P18310.cyclops.zoidte
                              chnologies.com [ file ]
Source                        local
Source Path                   /usr/libexec/postfix/local
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.9.7-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-106.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.4-101.fc18.i686 #1 SMP Thu
                              Oct 10 14:33:33 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-10-30 09:11:07 EDT
Last Seen                     2013-10-30 09:11:07 EDT
Local ID                      057b2572-aa3a-4758-bd05-98fea269e959

Raw Audit Messages
type=AVC msg=audit(1383138667.482:52346): avc:  denied  { write open } for  pid=18310 comm="local" path="/root/Maildir/tmp/1383138667.P18310.cyclops.zoidtechnologies.com" dev="dm-1" ino=1720834 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=file


type=SYSCALL msg=audit(1383138667.482:52346): arch=i386 syscall=open success=no exit=EACCES a0=b96e04c8 a1=80c1 a2=180 a3=b96e04c8 items=0 ppid=1466 pid=18310 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=local exe=/usr/libexec/postfix/local subj=system_u:system_r:postfix_local_t:s0 key=(null)

Hash: local,postfix_local_t,admin_home_t,file,write,open

audit2allow

#============= postfix_local_t ==============
allow postfix_local_t admin_home_t:file { write open };

audit2allow -R
require {
	type admin_home_t;
	type postfix_local_t;
	class file { write open };
}

#============= postfix_local_t ==============
allow postfix_local_t admin_home_t:file { write open };


Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.4-101.fc18.i686
type:           libreport
Comment 1 Daniel Walsh 2013-11-04 11:46:36 EST
*** Bug 1024791 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2013-11-04 11:49:09 EST
Mislabled files

restorecon -R -v /root

Should fix the labels.
Comment 3 Daniel Walsh 2013-11-04 11:56:16 EST
*** Bug 1024974 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.