Bug 1024974 - SELinux is preventing /usr/libexec/postfix/local from 'remove_name' accesses on the directory 1383147067.P22300.cyclops.zoidtechnologies.com.
SELinux is preventing /usr/libexec/postfix/local from 'remove_name' accesses ...
Status: CLOSED DUPLICATE of bug 1024849
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:039b0dc1017c8866e83c3bc2ac6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 13:04 EDT by Jeff MacDonald
Modified: 2013-11-04 11:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 11:56:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff MacDonald 2013-10-30 13:04:13 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/local from 'remove_name' accesses on the directory 1383147067.P22300.cyclops.zoidtechnologies.com.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that local should be allowed remove_name access on the 1383147067.P22300.cyclops.zoidtechnologies.com directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep local /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_local_t:s0
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                1383147067.P22300.cyclops.zoidtechnologies.com [
                              dir ]
Source                        local
Source Path                   /usr/libexec/postfix/local
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.9.7-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-106.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.11.4-101.fc18.i686 #1 SMP Thu
                              Oct 10 14:33:33 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-10-30 11:31:07 EDT
Last Seen                     2013-10-30 11:31:07 EDT
Local ID                      89e8ae22-78e9-4712-86d7-f3081a7dfde4

Raw Audit Messages
type=AVC msg=audit(1383147067.207:53971): avc:  denied  { remove_name } for  pid=22300 comm="local" name="1383147067.P22300.cyclops.zoidtechnologies.com" dev="dm-1" ino=1726084 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir


type=AVC msg=audit(1383147067.207:53971): avc:  denied  { unlink } for  pid=22300 comm="local" name="1383147067.P22300.cyclops.zoidtechnologies.com" dev="dm-1" ino=1726084 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=file


type=SYSCALL msg=audit(1383147067.207:53971): arch=i386 syscall=unlink success=yes exit=0 a0=b88343f8 a1=b8834550 a2=b77d5a80 a3=b6801708 items=0 ppid=1466 pid=22300 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=local exe=/usr/libexec/postfix/local subj=system_u:system_r:postfix_local_t:s0 key=(null)

Hash: local,postfix_local_t,admin_home_t,dir,remove_name

audit2allow

#============= postfix_local_t ==============
allow postfix_local_t admin_home_t:dir remove_name;
allow postfix_local_t admin_home_t:file unlink;

audit2allow -R
require {
	type postfix_local_t;
}

#============= postfix_local_t ==============
auth_filetrans_admin_home_content(postfix_local_t)
userdom_delete_admin_home_files(postfix_local_t)


Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.4-101.fc18.i686
type:           libreport
Comment 1 Daniel Walsh 2013-11-04 11:56:16 EST

*** This bug has been marked as a duplicate of bug 1024849 ***

Note You need to log in before you can comment on or make changes to this bug.