Bug 1024992 - Broken dependency when upgrading F19 -> F20
Broken dependency when upgrading F19 -> F20
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dayplanner (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On: 1008476
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 13:34 EDT by Dag Odenhall
Modified: 2013-11-03 03:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-03 03:16:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Odenhall 2013-10-30 13:34:32 EDT
Steps to Reproduce:
1. Install F19
2. Install dayplanner
3. yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates distro-sync

(Tested on my desktop, and not a clean F19 install.)

Actual results:

Error: Package: dayplanner-0.11-1.fc20.noarch (updates-testing)
           Requires: perl(Date::HolidayParser::iCalendar) >= 0.4

Additional info:

http://www.paulmellors.net/donate-1-minute-of-your-time-to-test-upgrades-from-f19-to-f20/
Comment 1 Christopher Meng 2013-10-30 22:36:59 EDT
Yeah I know, f20 is in freeze now and I've solved the dependency problem.

This perl module is bundled in the dayplanner 0.10-, from 0.11+ this is a separate module available on CPAN.

Note You need to log in before you can comment on or make changes to this bug.